NEW CyberAdmin Skin - The best skin ever made for DirectAdmin so far, coming soon!

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.7.1

Changes and new features / Modificaciones y mejoras:

  • Fix error on license verification call / Corrección de error en la llamada a la verificación de licencia


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
I'm actually facing a strange issue, one of my DA Server is reporting a "Response not valid" on the Skin License, so all my customers can't use the Control Panel because they receive an error about the license itself.
Hi SeLLeRoNe,

Thanks for report this issue.

King regards
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.7.2

Changes and new features / Modificaciones y mejoras:

  • Update DNS Settings to add DNSSEC table / Actualización de Gestión de DNS para añadir la tabla DNSSEC
  • Update MX list values in DNS Settings and MX Records / Actualización de la lista de valores MX en Gestión de DNS y Registros MX
  • Update Skin Manager to improve checks for required functions / Actualización de Gestión de Skins para mejorar la comprobación de funciones requeridas
  • Update the spanish translation / Actualización de la traducción al castellano
  • Update to detect languages from lang folder / Actualización para detectar idiomas desde la carpeta lang
  • Fix styles in File Manager / Corrección de estilos en Gestor de Archivos
  • Fix styles in Confirmation panel / Corrección de estilos en el panel de Confirmación
  • Fix styles in DNS Settings / Corrección de estilos en Gestión de DNS
  • Fix styles in Messaging System / Corrección de estilos en Sistema de Mensajes
  • Fix styles in FTP Setup / Corrección de estilos en Gestión de FTP
  • Fix styles in Summary Admin for process states / Corrección de estilos en Resumen Administrador para el estado de procesos


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.7.3

Changes and new features / Modificaciones y mejoras:

  • Add Turkish language / Añadido idioma Turco
  • Update to improve Spanish translation / Actualización para mejorar traducción al Español


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.7.4

Changes and new features / Modificaciones y mejoras:

  • Update the 'Summary Reseller' panel to add a user counter / Actualización del panel 'Resumen Reseller' para añadir un contador de usuarios
  • Update the Skin Manager panel to add 'Disable SSL' configuration / Actualización del panel 'Gestionar Skins' para añadir la configuración 'Desactivar SSL'
  • Update to remove the mandatory configuration of ssl_ignore_when_local / Actualización para eliminar la configuración obligatoria de ssl_ignore_when_local
  • Update to improve Turkish translation / Actualización para mejorar traducción al Turco


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,789
Location
A Coruña, Spain
Hi Javier,

after this update i've got this error:

Error performing query
Unknown SSL protocol error in connection to 127.0.0.1:2222

Apparently it does appear only for admin (which is good).

DA is set to use SSL on default port 2222.

Any hint?

Thanks

Best regards
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
Hi SeLLeRoNe,

In the Skin Manager there is a new configuration option called 'Disable SSL'. This option disables SSL for the internal api calls. Try to enable it.

Regards,
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
Thanks, i didn't notice that, actually was enough to set the option "ssl_ignore_when_local" to 0 :)
In a previous version we forced to set ssl_ignore_when_local=1 to improve the internal api calls. After this decision we have found that some plugins does not work with this configuration (Installatron for example), so we have made a rollback to these changes and added this new option to the panel for these users that prefer to configure ssl_ignore_when_local=1.
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,789
Location
A Coruña, Spain
Hi Javier, please see attached few screnshots of graphic glitch i'm seeing:

CWAF: Not sure it depend by the skin (probably not), the menu goes under the CWAF panel
CWAF.PNG
BFM: The output is messy, the "Advanced search" button is almost completely hidden
BFM.PNG
MAIN_PAGE: The RAM goes almost on the next info, maybe the space can be increased (there should be margin on the external to do that).
MAIN_PAGE.PNG

Best regards
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
Hi SeLLeRoNe,

Thanks for your report. We'll try to solve this as soon as possible.

King regards
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.7.5

Changes and new features / Modificaciones y mejoras:

  • Update 'Brute Force Monitor' panel to improve visualization / Actualización del panel 'Monitor Fuerza Bruta' para mejorar la visualización
  • Update 'Details for user' panel to open logs and statistics pages in a new window / Actualización del panel 'Detalles del usuario' para abrir páginas de logs y estadíscitcas en una ventana nueva
  • Update 'Edit Email Message' window to improve response after save / Actualización de la ventana 'Editar Mensaje de Email' para mejorar la respuesta al guardar
  • Fix styles in 'Summary Admin' dashboard for Memory and Swap values / Corrección de estilos de los valores Memoria e Intercambio del panel 'Resumen Administrador'
  • Fix styles in plugin Comodo WAF / Corrección de estilos en el plugin Comodo WAF
  • Fix and improve the translations for spanish language / Corrección y mejora de las traducciones del idioma español


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.8.0

Changes and new features / Modificaciones y mejoras:

  • Add a new package to add support for PHP 7 / Añadido nuevo paquete para dar soporte a PHP 7
  • Fix and improve the translations for spanish language / Corrección y mejora de las traducciones del idioma español


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.9.0

Changes and new features / Modificaciones y mejoras:

  • Add disable auto-renew option to Let's Encrypt in 'SSL Certificates' panel / Añadida opción para desactivar la auto renovación en el panel 'Certificados SSL'
  • Add language file to translate difficult_password.php / Añadido fichero de idiomas para traducir difficult_password.php
  • Update 'Manage User Backups' panel to add 'append path' options / Actualizado panel 'Gestión de Backups de Usuario' para añadir opciones 'añadir a la ruta'
  • Fix add IP in 'Domain Modify' panel / Corrección al añadir IP en panel 'Modificar Dominio'
  • Fix link for 'Domain Setup' button / Corrección del enlace del botón 'Configurar Dominio'


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,855
Location
GMT +7.00

javiern

Verified User
Joined
May 6, 2014
Messages
98
New release v1.10.0

Changes and new features / Modificaciones y mejoras:

  • Update 'SSL Certificates' to enlarge the textarea for 'Paste a pre-generated certificate and key' / Actualizado 'Certificados SSL' para agrandar el textarea de 'Pegar un certificado pre-generado y su llave (key)'
  • Fix errors in 'File Manager' related to new json funcionality added in DA 1.51 / Corrección de errores en el 'Gestor de archivos' relacionados con la nueva funcionalidad json añadida en DA 1.51


IMPORTANT
Due to the fact that ionCube has been removed support for oldest versions of the Loader,
CyberAdmin, from version 1.4.2, will only be compatible with versions of ionCube Loader 4+.
With versions of the ionCube Loader prior to 4, CyberAdmin 1.x.x may stop working.
Please, feel free to comment or ask about this issue.


IMPORTANTE
Debido a que ionCube ha eliminado el soporte para versiones antiguas del Loader, CyberAdmin,
a partir de su versión 1.4.2, solo será compatible con versiones de ionCube Loader 4+.
Con versiones del ionCube Loader anteriores a la 4, CyberAdmin 1.x.x podría dejar de funcionar.
Por favor, le invitamos a comentar o consultar cualquier duda que tenga al respecto.



UnZIP the file first in your PC, then upload the TAR.GZ file you extracted vía the skin manager replacing any previous versions you have
installed with this one.All bugs have been fixed. If you find any issues please report it here on this thread. Thank you!
 

jkirker

Verified User
Joined
Nov 22, 2012
Messages
97
Would it be possible in the next version of the skin to start applying css classes and id's to the various elements?

This would be of great value because it'd allow us some control over the display.

For instance, we do not offer any email services as part of our hosting - but Webmail and Squirrelmail icons are still visible on our clients control panels. I'd like to turn them off but have a limited ability to. In fact, your app should probably check on the conditions for these and turn them off when there are no mail accounts available.

Thoughts?
 

javiern

Verified User
Joined
May 6, 2014
Messages
98
Would it be possible in the next version of the skin to start applying css classes and id's to the various elements?
This would be of great value because it'd allow us some control over the display.
This could be an arduous enterprise, but we take note for Skin CyberAdmin 2.0.

For instance, we do not offer any email services as part of our hosting - but Webmail and Squirrelmail icons are still visible on our clients control panels. I'd like to turn them off but have a limited ability to. In fact, your app should probably check on the conditions for these and turn them off when there are no mail accounts available.
You can disable phpMyAdmin and webmail clients from Skin Manager panel, in section Tools & Webmail. Have you tried this?
 
Top