No apache MPM package installed

autotron

Verified User
Joined
Jul 7, 2011
Messages
7
Just reinstalled DA and all seems fine, ip shows the standard "it works" info shows
Server API Apache 2.0 Handler
apache2handler
Apache Version Apache/2
Apache API Version 20051115
Server Administrator webmaster@localhost
Hostname:port localhost:0
User/Group apache(1000)/110
Max Requests Per Child: 10000 - Keep Alive: on - Max Per Connection: 100
Timeouts Connection: 60 - Keep-Alive: 1
Virtual Server Yes
Server Root /etc/httpd
Loaded Modules core mod_authn_file mod_authn_default mod_authz_host mod_authz_groupfile mod_authz_user mod_authz_default mod_auth_basic mod_include mod_filter mod_deflate mod_log_config mod_logio mod_env mod_expires mod_headers mod_unique_id mod_setenvif mod_version mod_proxy mod_proxy_connect mod_proxy_ftp mod_proxy_http mod_proxy_scgi mod_proxy_ajp mod_proxy_balancer mod_ssl prefork http_core mod_mime mod_dav mod_status mod_autoindex mod_asis mod_suexec mod_cgi mod_dav_fs mod_dav_lock mod_negotiation mod_dir mod_actions mod_userdir mod_alias mod_rewrite mod_so mod_php5


I am trying to install memcached but now need to restart apache2 when I do
server:/# /etc/init.d/apache2
I get
No apache MPM package installed

I did
server:/# whereis apache2
and get
apache2: /usr/sbin/apache2 /etc/apache2 /usr/lib/apache2 /usr/lib64/apache2 /usr/share/apache2 /usr/share/man/man8/apache2.8.gz

any ideas?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,854
Location
GMT +7.00
For Debian it is /etc/init.d/httpd not /etc/init.d/apache2. Thus I guess you've got two copies of installed apache from custombuild and apt-get/aptitude. You should delete that one installed by apt-get/aptitude.
 
Top