Permanent changes in domains' httpd.conf

jep

Verified User
Joined
Nov 12, 2003
Messages
79
Hi,

How can I permanently change things in the virtualhost of my domain? For example i have domein.nl, then i have a httpd.conf for it. When i make changes in this file, it's getting overwritten.

Note: I want to allow some directory's for cgi-execution..

Jesper
 

jep

Verified User
Joined
Nov 12, 2003
Messages
79
Ok, good ;)

Something is strange here. I'm moving a site from a client with a lot of serverside includes to directory's like ../../. In the manual of mod_includes, I read that it's not possible to include outside your current directory..

Is this really impossible? That's kinda ugly.. :p I'm moving this files from another box (ensim i think), and there it works.

For example, ../../bla.css should go 2 directory's back, but it just says /home/site/public_html/sub/sub/bla.css not found (while i'm trying to link to ../../bla.css. Straaaaaange..

Any clue?
 

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
jep said:
Any clue?
No, but this isn't a simple case of slash 'n dot confuzzlment, is it?

Well, be it, or be it not, I think this thread is misplaced. Shouldn't things like this reside elsewhere? (i.e., in the Apache (WWW) support forum? ;) Maybe? :) )
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,021
Hello,

You might want to look into the "custom httpd.conf" feature (Admin Panel -> Admin Settings -> Customize httpd.conf -> domain.com).. or the virtual_host*.conf templates ( /usr/local/directadmin/data/templates/ ), depending on what you need to do.

John
 

jep

Verified User
Joined
Nov 12, 2003
Messages
79
ProWebUK helped me a lot on ICQ, but there is still one problem.

I made virtualhost without any strange arguments (just with servername, logfile and documentroot) and includes don't work over there. When i visit the same shtml file using the 'normal' document-root url (nog subdomain.bla.nl/file.shtml but /home/account/public_html/subdomain/file.shtml, it works perfectly :).

To ensure that all options are enabled on the virtualhosts I made, I use this :

<Directory "/home/recreatief/">
Options +Includes MultiViews FollowSymLinks ExecCGI Indexes
AddType text/html .shtml
AddHandler server-parsed .shtml
AllowOverride all
Order allow,deny
Allow from all
</Directory>

(The virtualhost are made by my scripts because my client had some very big files with virtualhosts.. i parsed them into the right format.
 
Top