Ping returns name or service not known

mbsmt

Verified User
Joined
Jul 24, 2013
Messages
129
Location
Mashhad, Iran
Hi.
I have a VPS which DA is installed on it. Everything works well on this machine, except DNS!
I found it as I faced with LetsEncrypt errors while generating SSL. After some searches, I understood DNS is the main cause of problems.
For example, when I run the code below on the domain which is set on server, I get errors:
Ping:
ping domain.net
Result:
ping: domain.net: Name or service not known
Whereas, if I ping other domains, there is no problem. I have other issues too while running CURL on a path on the server domain. To know more, there is not any problem on reaching website pages from outside of server and all of them are working.

(For some reasons, I had to write a sample domain).
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
672
Location
Murfreesboro
Marhabaan
It is really hard to help you with this type of stuff when you Redact your domain name. I hope you fixed it already but just incase.

But here it goes.

First if your DA server is the DNS server for that domain and it is setup correctly. Once you add the domain to the server it can take up to 48 hours to Propagate across the entire internet. In general I find 2 - 4 hours is good in most cases. Then try LE again.

If you are wondering if its set up correctly you can use
The one called DNS report should help you find Failures and Warnings

You could also Run
Code:
dig NS domain.net
When you do this do you get a list of Name servers that control that domain . (Domain.net). If the Name and Ip of the Server which should be controlling the said DA server. You will need to add it to your Domain Name at the registrar for domain.net.

Ma’assalama
 

mbsmt

Verified User
Joined
Jul 24, 2013
Messages
129
Location
Mashhad, Iran
After different checks, we found out the problem is because of DNSSEC which had enabled on our domain. After disabling, the problem sovled.
 
Top