Plugins and new skin

vbabichev

New member
Joined
Sep 10, 2018
Messages
4
Hello.

We have problems with charset in plugins when using evolutions skin.

Because of iframe using for plugins in new skin charset should be defined in head of iframe. Now it isn't defined and browser use ISO-8859-5 by default. English texts are showing without any problems, but when we use Russian we have problems.

Can you set utf-8 for plugin iframes?
 

vbabichev

New member
Joined
Sep 10, 2018
Messages
4
Thanks.

Another problem. Evolution don't load plugin which have name with dash. Can you enable this?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,329
Location
LT, EU
What's the name of the plugin? We were unable to reproduce the problem. Do you see any errors in browser console?
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
For anyone who needs to know, the plugin names must be:
a-z A-z 0-9 - _
which includes dash and underscore (no spaces)
 

vbabichev

New member
Joined
Sep 10, 2018
Messages
4
There are no errors in console.

In debug mode DirectAdmin returns correct output of plugin page.

I tried to install hello_world plugin from your site and renamed directory and id in plugin.conf to hello-world. As result evolution doesn't add iframe to page like before.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,329
Location
LT, EU
It was a bug in Evolution skin (regex allowing only A-Za-z_), which has been fixed now :) Please try updating the skin. Thank you for the report!
 
Top