problem building custombuild 1.2

Equand

Verified User
Joined
Feb 27, 2006
Messages
46
Found /usr/local/directadmin/custombuild/httpd-2.2.9.tar.gz
Extracting /usr/local/directadmin/custombuild/httpd-2.2.9.tar.gz...
Configuring httpd-2.2.9
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking build system type... config.sub: missing argument
Try `config.sub --help' for more information.
configure: error: /bin/sh build/config.sub failed
/usr/local/directadmin/custombuild/configure/ap2/configure.apache: --with-ssl=/usr: not found

*** There was an error while trying to configure Apache 2. Check the configure/ap2/configure.apache file

anybody help
system already has customapache 1.3 installed with php4 - the most simple installation out of the box of directadmin
i need to upgrade it to ap2+php5+zend optimizer
FreeBSD ##### 6.3-RELEASE FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:45:45 UTC 2008 root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP i386
 
Last edited:

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,340
Location
LT, EU
Did you touch /usr/local/directadmin/custombuild/configure/ap2/configure.apache ?
 

Equand

Verified User
Joined
Feb 27, 2006
Messages
46
all i did is ./build all
i didn't touch configs except for adding optimizer in options
 

nmb

Verified User
Joined
Sep 13, 2008
Messages
204
Got similar error with custombuild 1.2 and CentOS 5.2 64 bits. Tried 1.1 with another machine before and didn't have problem like this. Also, just tried 1.1 on the same machine that has problem with 1.2 and it works flawlessly.


Code:
Backing up certificate and key, and turning off httpd for DirectAdmins's check.
Found /usr/local/directadmin/custombuild/httpd-2.2.9.tar.gz
Extracting /usr/local/directadmin/custombuild/httpd-2.2.9.tar.gz...
Configuring httpd-2.2.9
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking build system type... config.sub: missing argument
Try `config.sub --help' for more information.
configure: error: /bin/sh build/config.sub   failed
/usr/local/directadmin/custombuild/configure/ap2/configure.apache: line 33: --with-ssl=/usr: No such file or directory

*** There was an error while trying to configure Apache 2. Check the configure/ap2/configure.apache file
________
EXPERT INSURANCE
 
Last edited:

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,923
Hello,

I've made a very slight change to the configure.apache in the 1.2 configure.apache file. There was a single space after the \ character, which seems to affect the configure on some boxes. The space is gone now. Do "./build update" and try again.

John
 
Top