PROBLEM recompiling width PHP5, LIBXML

internet-system

New member
Joined
Jan 23, 2007
Messages
1
Hi

I have tryed to recompile apache 2.2, with php 5

I got the following error message
Code:
Configuring extensions
checking whether to enable LIBXML support... yes
checking libxml2 install dir... no
checking for xml2-config path...
configure: error: xml2-config not found. Please check your libxml2 installation.
--disable-libxml: not found

*** There was an error while trying to configure php. Check the configure.php fi
The problem remains when i removed --disable-libxml


I have also tryed to
cd /usr/ports/textproc/libxml2/
make install clean
make
make install

With al the 3 options i got the following error message

Code:
===>  Building for libxml2-2.6.20
gmake: Makefile: No such file or directory
gmake: *** No rule to make target `Makefile'.  Stop.
*** Error code 2

Stop in /usr/ports/textproc/libxml2.
Is there anybody who can help me??
 

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
yum install -y libxml2-devel
yum? lol, this is forum for freebsd.
install of beta apache is broken.
try:
cp configure.php4_ap2 configure.php4

cp configure.php5_ap2 configure.php5

and try again the build. May this can help.
Also you can wait some days until the new beta version released.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,461
Location
LT, EU
Oops, sorry :) Didn't see that (looking new posts). I've rewritten beta script, it should be uploaded soon (it contains suPHP and some great new features).
 
Top