PSA: CustomBuild2 update Warning fread() expects parameter 1 to be resource

BarryStaes

Verified User
Joined
Sep 6, 2016
Messages
18
PSA: If you get this error after starting a CustomBuild update:

Code:
Executing /usr/local/directadmin/plugins/custombuild/admin/build update_versions.
Warning: fopen(/usr/local/directadmin/plugins/custombuild/logs/1558335768.29804.log): failed to open stream: No such file or directory in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 21
Warning: fread() expects parameter 1 to be resource, bool given in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 26
Warning: fread() expects parameter 1 to be resource, bool given in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 26

.. many more every second

Warning: fread() expects parameter 1 to be resource, bool given in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 26
Warning: fread() expects parameter 1 to be resource, bool given in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 26
Warning: fclose() expects parameter 1 to be resource, bool given in /usr/local/directadmin/plugins/custombuild/admin/build_software_command.raw on line 47
Done!
The loop may take a while, but it completes. Wait for the Done!
I noticed people didnt realize this so i wanted to put this PSA here. The update works fine, its just the log output thats broken.

The actual problem here is the fopen() error, the fread() that people search for online is just a symptom.

I dont know the cause of the fopen() error though, and the file does exist and contain some output.
 
Last edited:
Top