RainLoop webmail support / CustomBuild

Erulezz

Verified User
Joined
Sep 14, 2015
Messages
436
Location
Arnhem, NL
I came across the following webmail software project:

-RainLoop
https://www.rainloop.net

-Demo:
https://mail.rainloop.net

The demo looks very good. Also full mobile support. Now that RoundCube is the only modern software package in DirectAdmin, is it worth considering supporting it in CustomBuild?

And yes, I know that it is also possible to install this manually! But if it works well it might be nice to have a second choice next to RoundCube which you can easily install in CustomBuild.
 

xerox

Verified User
Joined
Jul 16, 2019
Messages
65
Hello,

Using it for a while.

You can find an installer rainloop.install.sh for Directadmin here: https://github.com/poralix/directadmin-utils/tree/master/webapps

Agree, it's good.

But i get an error with the installation script using centos 7.

Code:
cd /root
wget https://github.com/poralix/directadmin-utils/blob/master/webapps/rainloop.install.sh
chmod 755 rainloop.install.sh
./rainloop.install.sh
output:
Code:
[root@server ~]# ./rainloop.install.sh
./rainloop.install.sh: line 7: syntax error near unexpected token `newline'
./rainloop.install.sh: line 7: `<!DOCTYPE html>'
 

xerox

Verified User
Joined
Jul 16, 2019
Messages
65
Great! Installation was success!
Is there a way to automatically add all directadmin domains to rainloop and are new domains is added automatically? I'm missing something?

Also if i use the plugin: directadmin-change-password, then what should be the pattern?

Thanks"
 
Last edited:

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
You don't need to add all domains, you can go with a wildcard * and it will be sufficient. Probably I will add it into the installation script later.
 

ssgill

Verified User
Joined
May 9, 2012
Messages
88
Hello, i installed rainloop and its working fine. Only issue is its only available at server.domain.com/rainloop.
Is it possible it can be accessed from domain.com/rainloop, i have added alias in custom webapp. I have roundcube thats set as default at webmail_link and i would like to keep it that way.
Thanks
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
It's working on all domains for me. I use the same script for installation as posted here in the post #5
 

ssgill

Verified User
Joined
May 9, 2012
Messages
88
Hello Alex, thanks for the reply. I figure it has something to do with rewrite_config command, that's not updating /etc/httpd/conf/extra/httpd-alias.conf.

File permissions:
[root@moadmin custombuild]# ls -al /etc/httpd/conf/extra/httpd-alias.conf
-rw-r--r-- 1 root root 218 Sep 5 09:40 /etc/httpd/conf/extra/httpd-alias.conf

[root@moadmin custombuild]# lsattr /etc/httpd/conf/extra/httpd-alias.conf
---------------- /etc/httpd/conf/extra/httpd-alias.conf
custom webapps list

[root@matrix moadmin ]# cat custom/webapps.list
rainloop=rainloop


Rewrite config command result

[root@moadmin custombuild]# ./build rewrite_confs
Checking to ensure /etc/httpd/conf/ssl.crt/server.ca is set.
Using *.*.*.59 for your server IP
Installing Comodo Rule Set for ModSecurity...
Downloading cwaf_rules-1.219.tgz...
--2019-09-05 09:40:12-- https://waf.comodo.com/api/da_vendor?file=cwaf_rules-1.219.tgz
Resolving waf.comodo.com (waf.comodo.com)... 178.255.86.135
Connecting to waf.comodo.com (waf.comodo.com)|178.255.86.135|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 352062 (344K) [application/x-gzip]
Saving to: '/usr/local/directadmin/custombuild/cwaf_rules-1.219.tgz'

100%[===============================================================================================================================================================================================>] 352,062 372KB/s in 0.9s

2019-09-05 09:40:14 (372 KB/s) - '/usr/local/directadmin/custombuild/cwaf_rules-1.219.tgz' saved [352062/352062]

Updating to latest CWAF client version
current version is up to date
update process finished!
Defaulting to Comodo WAF SecDefaultAction...
Installation of ModSecurity Rule Set has been finished.
PHP has been secured.
Restarting php-fpm70.
Restarting php-fpm72.
Restarting php-fpm71.
Defaulting to Comodo WAF SecDefaultAction...
Restarting apache.
This is not updating /etc/httpd/conf/extra/httpd-alias.conf. Manually adding alias in file works

I am following KB : https://help.directadmin.com/item.php?id=599

Thanks
 

rotame

Verified User
Joined
Jul 4, 2019
Messages
52
Hi,

Fantastic work, thanks alot
Need considered to add to custombuild
 
Top