[release] Installatron v2.2

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
Installatron provides DirectAdmin users with the ability to easily install and upgrade a growing list of web scripts. See www.installatron.com for details.

--

iTron version 2.2 includes experimental remote MySQL server support. Though we do not see any issues in the implementation of this feature, we can not guarantee this feature bug free yet. That is, do not change the Remote MySQL setting from 'localhost' unless you know what you're doing :)

As always, any issues uncovered in this release will be promptly fixed through a version 2.3 release candidate.

--

To upgrade to this version, simply navigate to the DirectAdmin Plugin Manager and click the 'Upgrade' button for 'Installatron'.

To install this version on a new server, see this guide: http://www.installatron.com/installation

--

Enjoy. :)
 

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
I've also updated the following packages with miscellaneous innovations:
  • phpBB
  • osCommerce
  • Coppermine
  • Directory
  • Mambo
And I've added this script as a new package:
  • PostNuke
Enjoy!
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

Houston we have a problem...

Here's what I get upon install... It also appears on the "Installatron Admin" page...

The file /usr/local/directadmin/plugins/iTron/engine/libraries/misc.php has been encoded with the ionCube PHP Encoder and requires the free ioncube_loader_lin_4.3.so ionCube PHP Loader to be installed.Plugin Installed!

This was a clean install without any existing iTron directory...

Are the ioncube files missing?

David
 
Last edited:

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
There we go. Just "delete" what part of it installed, and reinstall. :)

"If it's not tested, it's broken."
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

Well, you learn certainly more from broken things by simply having to fix them...

David
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey Phil,

Installed with no problems... Great work... Thanks

David
 

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
skruf said:
Hey,

Well, you learn certainly more from broken things by simply having to fix them...

David
That is very true :)

Lets just hope it's fixed this time 'round :p
 

motobrandt

Verified User
Joined
Jan 8, 2004
Messages
217
PHPshop

I get this after PHPshop install.


Warning: main(home/phpshop/etc/phpshop.cfg): failed to open stream: No such file or directory in /usr/home/blibrandt/domains/bli.net/public_html/phpshop/index.php on line 65

Fatal error: main(): Failed opening required 'home/phpshop/etc/phpshop.cfg' (include_path='.:/usr/local/lib/php') in /usr/home/blibrandt/domains/bli.net/public_html/phpshop/index.php on line 65

This is at the main page.
 

Sumaleth

Verified User
Joined
Jul 27, 2003
Messages
209
I get this after PHPshop install.
I just uploaded a new build of the phpShop package. If you go into the DA plugin manager and [Update] Installatron you'll get it (the itron core will still say 2.2, ignore that).
 

motobrandt

Verified User
Joined
Jan 8, 2004
Messages
217
thanks I'll give her a shop.

I'm also having a problem with a site that I just added. When he installs mambo it is leaving the group as apache and then he doesn't have permission to do anything apparantly. I changed the grp to hisusername and everything worked fine. Oversight or??

Thanks I know this will evolve into a great thing. Hell it already is!

On a side note check this out.
http://www.jamroom.net/about.shtml
This would be a great addition. :)
cheers
brandt
 

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
I've uploaded updates for Pivot and Gallery. To update, go into the DA plugin manager and [Update] Installatron. Note that the iTron core will still say 2.2.

As for file owner sometimes setting to 'apache' - iTron is run as the user installing the script, so I'm not sure if there is anything we can do. However, I do plan to look into pre-creating 0-byte files for such scripts, although I'm not sure if these 0-byte files are just going to be overwritten or not.
 

l0rdphi1

Verified User
Joined
Jun 22, 2003
Messages
1,471
Hello everyone,

iTron version 2.3rc1 is up. This release includes our new package & language updating system along with a few small bug fixes.

This is not an essential release. You may opt to wait until version 2.3 final is released later this week. :)

Phi1.
 

Sumaleth

Verified User
Joined
Jul 27, 2003
Messages
209
GXX said:
i see it just tells you 'plugin update' without the whole list of scripts showing, is that supposed to be how it is?
Yes, in the earlier versions it reported on every package, but now it will only tell you when there is something to report -- a new or updated package, or an error.

Package/Language updating is now performed from the Installatron Administration page by the way.
 

Seth

Verified User
Joined
Oct 26, 2003
Messages
266
Location
USA
"Unable to execute your request
Details
The requested file does not have read or execute permissions"

ALSO:
Result While Updating Plugin(s)

Details
iTron successfully downloaded
Error unpacking /usr/local/directadmin/plugins/iTron/plugin.tar.gz : Error restoring file /usr/local/directadmin/plugins/iTron/plugin.tar.gz :


Is what I got after trying to update Installatron, what would be the proper permmisions?

thanks.
 
Last edited:

Sumaleth

Verified User
Joined
Jul 27, 2003
Messages
209
I think that permissions problem was an issue with DA 1.22.1, and we've been waiting on 1.22.2 before we can fix it (which actually looks like it was released today).

There'll be a new version of Installatron coming out soon.
 
Top