Roundcube can't receive or send emails to external mails

tonygs

Verified User
Joined
Jan 22, 2021
Messages
14
internal mails work well with two different domains (under the same DA host). however, outgoing mail failed.

I have a Unify gateway, it still not work after setting port (25, 465, 587 )

msg as following:

Warning: message 1lCUkY-003lAD-KI delayed 24 hours​

This message was created automatically by mail delivery software.
A message that you sent has not yet been delivered to one or more of its
recipients after more than 24 hours on the queue on server1.xxx.com.
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
2,971
Location
Murfreesboro
Are you trying to set this up in you home on a home internet connection?
it still not work after setting port (25, 465, 587 )
Are you saying you opened the ports or NATed them or both?

If you go to intodns.com and put in your domain info. Does it all resolve?

More detail about your setup would be helpful.
 

tonygs

Verified User
Joined
Jan 22, 2021
Messages
14
Are you trying to set this up in you home on a home internet connection?

Are you saying you opened the ports or NATed them or both?

If you go to intodns.com and put in your domain info. Does it all resolve?

More detail about your setup would be helpful.
please see attached.
 

Attachments

  • Capture.PNG
    Capture.PNG
    48.2 KB · Views: 11

Richard G

Verified User
Joined
Jul 6, 2008
Messages
6,776
Location
Maastricht
Any outgoing firewall which may block outgoing traffic?
Check your exim logs to see what it says there.
 

tonygs

Verified User
Joined
Jan 22, 2021
Messages
14
Any outgoing firewall which may block outgoing traffic?
Check your exim logs to see what it says there.
I was using DA firewall setting, all ports are normal (as default). I also forwarded all ports at the gateway.
please see the latest exim mainlog below:


2021-02-20 15:00:59 1lDYR1-0058eI-LY ** %external_email_address%@server.myserver.com <[email protected]> F=<[email protected]>: Unrouteable address
2021-02-20 15:00:59 cwd=/etc/csf 4 args: /usr/sbin/sendmail -f root -t
2021-02-20 15:00:59 1lDYR1-0058eM-Lj <= <> R=1lDYR1-0058eE-KY U=mail P=local S=2074 T="Mail delivery failed: returning message to sender" from <> for [email protected]
2021-02-20 15:00:59 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1lDYR1-0058eJ-LP
2021-02-20 15:00:59 1lDYR1-0058eE-KY Completed
2021-02-20 15:00:59 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1lDYR1-0058eI-LY
2021-02-20 15:00:59 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1lDYR1-0058eM-Lj
2021-02-20 15:00:59 1lDYR1-0058eJ-LP ** %external_email_address%@server.myserver.com <[email protected]> F=<>: Unrouteable address
2021-02-20 15:00:59 1lDYR1-0058eJ-LP Frozen (delivery error message)
2021-02-20 15:00:59 1lDYR1-0058eM-Lj ** %external_email_address%@server.myserver.com <[email protected]> F=<>: Unrouteable address
2021-02-20 15:00:59 1lDYR1-0058eM-Lj Frozen (delivery error message)
2021-02-20 15:00:59 1lDYR1-0058eQ-Ma <= [email protected] U=root P=local S=680 T="lfd on server.myserver.com: Excessive resource usage: rpc (955 (Parent PID:955))" from <[email protected]> for root
2021-02-20 15:00:59 1lDYR1-0058eS-Mk <= <> R=1lDYR1-0058eI-LY U=mail P=local S=2085 T="Mail delivery failed: returning message to sender" from <> for [email protected]
2021-02-20 15:00:59 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1lDYR1-0058eS-Mk
2021-02-20 15:00:59 1lDYR1-0058eS-Mk ** %external_email_address%@server.myserver.com <[email protected]> F=<>: Unrouteable address
2021-02-20 15:00:59 1lDYR1-0058eS-Mk Frozen (delivery error message)
2021-02-20 15:00:59 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1lDYR1-0058eQ-Ma
2021-02-20 15:00:59 1lDYR1-0058eI-LY Completed
2021-02-20 15:00:59 1lDYR1-0058eQ-Ma ** %external_email_address%@server.myserver.com <[email protected]> F=<[email protected]>: Unrouteable address
2021-02-20 15:00:59 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1lDYR1-0058eQ-Ma
2021-02-20 15:00:59 1lDYR1-0058ea-Nm <= <> R=1lDYR1-0058eQ-Ma U=mail P=local S=2052 T="Mail delivery failed: returning message to sender" from <> for [email protected]
2021-02-20 15:00:59 1lDYR1-0058eQ-Ma Completed
2021-02-20 15:00:59 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1lDYR1-0058ea-Nm
2021-02-20 15:00:59 1lDYR1-0058ea-Nm ** %external_email_address%@server.myserver.com <[email protected]> F=<>: Unrouteable address
2021-02-20 15:00:59 1lDYR1-0058ea-Nm Frozen (delivery error message)
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
6,776
Location
Maastricht
Unroutable address. Looks like a DNS issue. System can't find the domain it should send to.
What's your /etc/resolv.conf look like?
 

tonygs

Verified User
Joined
Jan 22, 2021
Messages
14
Unroutable address. Looks like a DNS issue. System can't find the domain it should send to.
What's your /etc/resolv.conf look like?
thanks for the prompt response. here the resolv.conf:


# Generated by NetworkManager
search localdomain myserverdomain.com
nameserver 192.168.1.1
 

jamgames2

Verified User
Joined
Aug 16, 2019
Messages
442
@tonygs
remove line
"nameserver 192.168.1.1"

then add some nameserver with external, Or select other dns by yourself
"nameserver 8.8.4.4"



It's shouldn't resolve with self server,
you need to use external resolve like "8.8.4.4"
 

tonygs

Verified User
Joined
Jan 22, 2021
Messages
14
@tonygs
remove line
"nameserver 192.168.1.1"

then add some nameserver with external, Or select other dns by yourself
"nameserver 8.8.4.4"



It's shouldn't resolve with self server,
you need to use external resolve like "8.8.4.4"
thanks!

I changed it to the following. it didn't work. also, it turns back to the original (self server) once I rebooted the system.

search localdomain vartell.com
nameserver 8.8.8.8
nameserver 8.8.4.4
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
6,776
Location
Maastricht
Try this if you're not running your own nameserver. Only keep this.
Code:
nameserver 1.1.1.1
nameserver 8.8.8.8
Then use this command:
Code:
chattr +i /etc/resolv.conf

Now reboot and see if the /etc/resolv.conf still gets overwritten, if all is good it won't.

I changed the first 8.8.8.8 to 1.1.1.1 because on Googles nameservers there are some limits present. You could run into that when using anti-spam measures. Cloudflare does not have that limit. So that's why I used that nameserver first and Googles as second.
 
Top