SMTP Isn’t working, can’t connect via SMTP port 587 even though it is open

tomwin

Verified User
Joined
Apr 23, 2020
Messages
76
Hi, When i check my to /etc/exim.variables.conf i do have this inside daemon_smtp_ports = 25 : 587
But when I trying to connect to google suite SMTP using smtp.google.com using port 587 I get error.
I do have IP-tables and CSV I think the name was.
Is there something I should do more to get it to work?
 

ericc

Verified User
Joined
Jan 2, 2018
Messages
92
Location
EU
Hi, When i check my to /etc/exim.variables.conf i do have this inside daemon_smtp_ports = 25 : 587
But when I trying to connect to google suite SMTP using smtp.google.com using port 587 I get error.
I do have IP-tables and CSV I think the name was.
Is there something I should do more to get it to work?

Your server's hostname is smtp.google.com?

Or you're trying to connect to to Google server from your server for some reason?
 

tomwin

Verified User
Joined
Apr 23, 2020
Messages
76
Hi, i was trying to use google suite SMTP because the outgoing registration email from my site is end up in inbox for spam
Or you're trying to connect to to Google server from your server for some reason?
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
1,837
Location
Murfreesboro
Hi, When i check my to /etc/exim.variables.conf i do have this inside daemon_smtp_ports = 25 : 587
But when I trying to connect to google suite SMTP using smtp.google.com using port 587 I get error.
I do have IP-tables and CSV I think the name was.
Is there something I should do more to get it to work?
If you connecting to google your not connecting to the DA server. You are connecting to google. Try setting up an App specific password in if you want to use google.

Also there are lots of reasons any New DA server email ends up in spam. The server is new on the internet and has no reputation. You also most likely have a whole lot of items like spf and reverses not setup.
 

tomwin

Verified User
Joined
Apr 23, 2020
Messages
76
Google search for "google app password"
finds this.
Hi, I have set up 2 step verification on my google account after I tried to connect SMTP to google g-suite again I get this error
smtpmail_fsock_error_initial
 

tomwin

Verified User
Joined
Apr 23, 2020
Messages
76
Trying to set up the SMTP and when I trying to save the new setting and it trying to connect to log in to my G-suite email then I get this error.
 

tomwin

Verified User
Joined
Apr 23, 2020
Messages
76
wherein what application? Is this for the IP boards application?
Yes it is. When I trying to save the settings. It will try to send out a test email to verify the the new settings is ok. Then this error turn up.
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
1,837
Location
Murfreesboro
Have you scoured there help files for how to set it up for the IP boards application? This wouldn't be in DA
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,673
Location
Maastricht
Try this one, maybe it helps:
SMTP host: smtp.google.com
SMTP protocol: SSL
SMTP port: 465

Be aware that also port 465 has to be opened on your server.
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
1,837
Location
Murfreesboro
Yes it is. I enter

SMTP host: smtp.google.com
SMTP protocol: TLS
SMTP port: 587
username: email@domain.com
pasword: password to my email
Might look here too.

If your SMTP server requires SSL or TLS you may need to prefix your SMTP Host with ssl:// or tsl:// to have the system recognize these requirements
 
Top