Something wrong with recent DA install:

floyd

Verified User
Joined
Mar 29, 2005
Messages
5,870
What are the permissions on the backup directory?
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
ls -l /home/admin

drwx--x--x 2 admin admin 4096 Jul 3 16:44 admin_backups
 
Last edited:

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,092
Checking the code, there are only 2 function calls that could return that error.
Either a stat() call, or opendir().
I've updated the DA code to include debug output, exactly level 433.

1) Grab the latest pre-release binaries.
2) go to the page in 2222 so that you're only 1 click away from generating that error.
3) run DA in debug mode 433
4) click the button to duplicate the error.

We'd be looking for either:
Sys::getDirFiles:%s: stat error as euid=%d: %s

or:
Sys::getDirFiles:%s: opendir error as euid=%d: %s

where the %s and %d bits would be replaced with relevant information.
The euid should be the admin uid from the "id admin" call. If it's a different number, then that's likely why.

Also makes sure that the:
Code:
ls -lad /home/admin
is 711.

John
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
Thanks John,
here is the result:


Debug mode. Level 433

DirectAdmin 1.61.3
Accepting Connections on port 2222
/CMD_JSON_LANG
GET string: json=yes&domain=domain.fi&initial=no&request=global&dynamic=yes
Checking referer https://x.x.x.x:2222/?redirect=yes to x.x.x.x:2222
auth.authenticated
User::deny_override:/CMD_JSON_LANG: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_JSON_LANG: call_level=1, depth2: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=1, depth2: aborting due to do depth
Command::doCommand(/CMD_JSON_LANG)
Command::doCommand(/CMD_JSON_LANG) : finished
Command::run: finished /CMD_JSON_LANG
/CMD_AJAX_SEARCH
GET string: json=yes&search=resto&users=yes&admins=yes&resellers=yes&domains=yes&email=yes&ftp=yes&db=yes&search_0=1&search_1=1&search_2=1&search_3=1&search_4=1&search_5=1&search_6=1&search_7=1&search_8=1
Checking referer https://x.x.x.x:2222/?redirect=yes to x.x.x.x:2222
auth.authenticated
User::deny_override:/CMD_AJAX_SEARCH: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_AJAX_SEARCH: call_level=1, depth2: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=1, depth2: aborting due to do depth
Command::doCommand(/CMD_AJAX_SEARCH)
Searching for 'resto'. usertype=3 users=1 resellers=1 admins=1 has_expired=0
Command::doCommand(/CMD_AJAX_SEARCH) : finished
Command::run: finished /CMD_AJAX_SEARCH
/CMD_SITE_BACKUP
GET string: json=yes&domain=domain.fi&ipp=50
Checking referer https://x.x.x.x:2222/?redirect=yes to x.x.x.x:2222
/CMD_SITE_BACKUP
GET string: json=yes&domain=domain.fi&ipp=50
Checking referer https://x.x.x.x:2222/?redirect=yes to x.x.x.x:2222
auth.authenticated
auth.authenticated
User::deny_override:/CMD_SITE_BACKUP: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_SITE_BACKUP: call_level=1, depth2: aborting due to do depth
User::deny_override:/CMD_SITE_BACKUP: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_SITE_BACKUP: call_level=1, depth2: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=1, depth2: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=2, depth1: aborting due to do depth
User::deny_override:/CMD_DOMAIN: call_level=1, depth2: aborting due to do depth
Command::doCommand(/CMD_SITE_BACKUP)
Sys::getDirFiles:/home/admin/backups: stat error: No such file or directory
Dynamic(api=0, error=1):
text='Cannot Execute Your Request'
result='Unable to read backups directory<br>
'
Command::doCommand(/CMD_SITE_BACKUP) : finished
Command::run: finished /CMD_SITE_BACKUP
Command::doCommand(/CMD_SITE_BACKUP)
Sys::getDirFiles:/home/admin/backups: stat error: No such file or directory
Dynamic(api=0, error=1):
text='Cannot Execute Your Request'
result='Unable to read backups directory<br>
'
Command::doCommand(/CMD_SITE_BACKUP) : finished
Command::run: finished /CMD_SITE_BACKUP


It seems that for some reason it is looking for /home/admin/backups and not /home/admin/admin_backups ?
 
Last edited:

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,092
CMD_SITE_BACKUP is the "User Level" backup tool.
You'd want to make your way over to the "Admin Level" first, then access the "Admin Backup/Transfer" tool.

John
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
Hi.
Im on the Admin level and I get to that location ( CMD_SITE_BACKUP ) if I use the Search function and type in restore.

The only result I get is "Restore backup" and that gives that error.
 
Last edited:

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
If I go straight to Admin Tools/Admin Backup (Transfer)/Restore and pick up the backup file to be restored from there I get this:

Unable to extract backup/user.conf from /home/admin/admin_backups/user.admin.name.tar.gz
Error while extracting backup/user.conf to /home/admin/admin_backups/name as admin : tar (child): /home/admin/admin_backups/user.admin.name.tar.gz: Cannot open: Permission denied
tar (child): Error is not recoverable: exiting now
/bin/tar: Child returned status 2
/bin/tar: Error is not recoverable: exiting now

-rw-r----- root root /home/admin/admin_backups/user.admin.name.tar.gz

Cannot read /home/admin/admin_backups/name/backup/user.conf : Unable to open /home/admin/admin_backups/name/backup/user.conf for reading.
No such file or directory
 

floyd

Verified User
Joined
Mar 29, 2005
Messages
5,870
The owner obviously needs to be admin not root.
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
" The owner needs to be admin. "

Thanks! Changed the owner to admin with chown, worked.

However I still get still weird looking search results when searching available functions. Take a look.
 

Attachments

  • DA-weird-search-result.jpg
    DA-weird-search-result.jpg
    74.1 KB · Views: 12

floyd

Verified User
Joined
Mar 29, 2005
Messages
5,870
That's what mine looks like. Are you not finding what you are looking for? Maybe you need a different search term. Personally I just use the menu since all of the functions are there.
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
Here is how it should look like:
 

Attachments

  • DA-normal-search-result.jpg
    DA-normal-search-result.jpg
    70 KB · Views: 10

floyd

Verified User
Joined
Mar 29, 2005
Messages
5,870
I only have 2 running evolution skin, one is fairly new and one is old and both look like jet1972's. So I guess its a bug somewhere.
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
Really weird stats, server date is July 5th 2020 (5.7.2020):
 

Attachments

  • DA-Bandwidth-stats-bug.jpg
    DA-Bandwidth-stats-bug.jpg
    109 KB · Views: 21
Last edited:

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,629
Location
LT, EU
Really weird stats, server date is July 5th 2020 (5.7.2020):
Likely related to wrong date format I guess. May you paste the output of /CMD_BANDWIDTH_BREAKDOWN?json=yes&year=2020&user=admin&ipp=500 ?
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
227
Sure:


2020 03 08
da"7652123"
day"08"
email"0"
email_count"0"
email_count_incoming"0"
email_count_outgoing"0"
ftp"0"
http"824"
http_homedir"0"
http_ul"353"
imap"0"
month"03"
other"0"
pop"0"
total"7652947"
year"2020"
2020 03 09
da"5139743"
day"09"
email"511410"
email_count"116"
email_count_incoming"114"
email_count_outgoing"2"
ftp"0"
http"3458211"
http_homedir"0"
http_ul"535443"
imap"1132129"
month"03"
other"0"
pop"0"
total"10241493"
year"2020"
2020 04 10
da"1702239"
day"10"
email"684942"
email_count"162"
email_count_incoming"162"
email_count_outgoing"0"
ftp"0"
http"1245059"
http_homedir"0"
http_ul"80565"
imap"0"
month"04"
other"0"
pop"0"
total"3632240"
year"2020"
2020 06 16
da"1390602250"
day"16"
email"5282"
email_count"6"
email_count_incoming"6"
email_count_outgoing"0"
ftp"0"
http"0"
http_homedir"0"
http_ul"0"
imap"0"
month"06"
other"0"
pop"0"
total"1390607532"
year"2020"
2020 06 21
da"0"
day"21"
email"327789"
email_count"50"
email_count_incoming"50"
email_count_outgoing"0"
ftp"0"
http"0"
http_homedir"0"
http_ul"0"
imap"0"
month"06"
other"0"
pop"0"
total"327789"
year"2020"
2020 07 04
da"4764446"
day"04"
email"607886"
email_count"78"
email_count_incoming"78"
email_count_outgoing"0"
ftp"0"
http"0"
http_homedir"0"
http_ul"0"
imap"0"
month"07"
other"0"
pop"0"
total"5372332"
year"2020"
month"0"
total
da"1409860801"
email"2137309"
email_count"412"
email_count_incoming"410"
email_count_outgoing"2"
ftp"0"
http"4704094"
http_homedir"0"
http_ul"616361"
imap"1132129"
other"0"
pop"0"
total"1417834333"
year"2020"
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,629
Location
LT, EU
May you confirm enhanced shows just a single entry there? 2020 07 04
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,629
Location
LT, EU
Please try pre-release for the bandwidth breakdown issue :)
 
Top