SpamAssassin 3.2.0 released!

rohit

Verified User
Joined
Mar 20, 2007
Messages
210
Location
Melbourne
it didn't work. It is complaining about HTML::parser perl module

ERROR: the required HTML::parser (version 3.43) module is installed,
but is not an up-to-date version. at lib/Mail/SpamAssassin/Util/DependencyInfo.pm line 293.


HTML is used for an ever-increasing amount of email so this dependency
is unavoidable. Run "perldoc -q html" for additional information.
 

rohit

Verified User
Joined
Mar 20, 2007
Messages
210
Location
Melbourne
The issue is with the version of HTML::parser perl module. The real issue lies with the /usr/local/directadmin/scripts/spam.sh file.

In this file the version of HTML::parser module that gets installed is

PARSER_VER=3.37

So what I did to get SpamAssassin 3.2.0 installed is

commented

downloadMake $PARSER_NAME

in /usr/local/directadmin/scripts/spam.sh file

then I downloaded and installed HTML-Parser-3.55 from cpan as HTML-Parser-3.56 has errors. For some reason, I see http://files.directadmin.com/services/9.0/ has HTML-Parser-3.56 tar ball, which I think John should remove and replace with 3.55.

I then ran ./update.script SPAMASSASSIN and it worked and didn't complain.

I then reverted back the changes for spam.sh file.

Hope there is some easier solution.
 

Timmm

Verified User
Joined
Sep 12, 2005
Messages
36
Location
Amsterdam, The Netherlands
same here with the parser. It is also missing some other modules so functionality will be limited but it fails to install on the html parser. I will use your update method Rohit. Is the error on 3.56 OS dependent?

BTW Wael although SpamAss. failed to install your update.script says it installed successfully...

***************************************************************************
ERROR: the required HTML::parser (version 3.43) module is installed,
but is not an up-to-date version. at lib/Mail/SpamAssassin/Util/DependencyInfo.pm line 293.


HTML is used for an ever-increasing amount of email so this dependency
is unavoidable. Run "perldoc -q html" for additional information.


***************************************************************************
NOTE: the optional Mail::SPF module is not installed.

Used to check DNS Sender Policy Framework (SPF) records to fight email
address forgery and make it easier to identify spams. (This is preferred
over Mail::SPF::Query.)


***************************************************************************
NOTE: the optional IP::Country module is not installed.

Used by the RelayCountry plugin (not enabled by default) to determine
the domain country codes of each relay in the path of an email.


***************************************************************************
NOTE: the optional Razor2 (version 2.61) module is not installed.

Used to check message signatures against Vipul's Razor collaborative
filtering network. Razor has a large number of dependencies on CPAN
modules. Feel free to skip installing it, if this makes you nervous;
SpamAssassin will still work well without it.

More info on installing and using Razor can be found
at http://wiki.apache.org/spamassassin/InstallingRazor .


***************************************************************************
NOTE: the optional Net::Ident module is not installed.

If you plan to use the --auth-ident option to spamd, you will need
to install this module.


***************************************************************************
NOTE: the optional IO::Socket::INET6 module is not installed.

This is required if the first nameserver listed in your IP
configuration or /etc/resolv.conf file is available only via
an IPv6 address.


***************************************************************************
NOTE: the optional Compress::Zlib module is not installed.

If you wish to use the optional zlib compression for communication
between spamc and spamd (the -z option to spamc), you need to install
this module.


***************************************************************************
NOTE: the optional Time::HiRes module is not installed.

If this module is installed, the processing times are logged/reported
more precisely in spamd.


***************************************************************************
NOTE: the optional Mail::DomainKeys module is not installed.

If this module is installed, and you enable the DomainKeys plugin,
SpamAssassin will perform Domain Key lookups when Domain Key
information is present in the message headers. (Note that new versions
of Mail::DKIM render this module superfluous.)


***************************************************************************
NOTE: the optional Mail::DKIM module is not installed.

If this module is installed, and you enable the DKIM plugin,
SpamAssassin will perform DKIM lookups when a DKIM-Signature
header is present in the message headers. (New versions of this module
support both Domain Keys and DKIM, rendering Mail::DomainKeys obsolete.)


***************************************************************************
NOTE: the optional DBI module is not installed.

If you intend to use SpamAssassin with an SQL database backend for
user configuration data, Bayes storage, or other storage, you will need
to have these installed; both the basic DBI module and the driver for
your database.


***************************************************************************
NOTE: the optional Archive::Tar (version 1.23) module is not installed.

The "sa-update" script requires this module to access tar update
archive files.


***************************************************************************
NOTE: the optional IO::Zlib (version 1.04) module is not installed.

The "sa-update" script requires this module to access compressed
update archive files.


***************************************************************************
NOTE: the optional Encode::Detect module is not installed.

If you plan to use the normalize_charset config setting to detect
charsets and convert them into Unicode, you will need to install
this module.

REQUIRED module out of date: HTML::parser
optional module missing: Mail::SPF
optional module missing: IP::Country
optional module missing: Razor2
optional module missing: Net::Ident
optional module missing: IO::Socket::INET6
optional module missing: Compress::Zlib
optional module missing: Time::HiRes
optional module missing: Mail::DomainKeys
optional module missing: Mail::DKIM
optional module missing: DBI
optional module missing: Archive::Tar
optional module missing: IO::Zlib
optional module missing: Encode::Detect

warning: some functionality may not be available,
please read the above report before continuing!

make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target `install'. Stop.


run:
/usr/bin/spamd -d -c -m 5

[2904] error: spamd: could not create INET socket on 127.0.0.1:783: Address already in use
spamd: could not create INET socket on 127.0.0.1:783: Address already in use
Shutting down exim:
Starting exim:


SpamAssassin update done

[screen is terminating]

EDIT: after commenting in spam.sh and updating HTML::parser to 3.56 (seems to be OK on Centos 4) it still gives errors as displayed above... says that version op Parser is out-of-date... but the version is 3.56 according (for example yum)...

Anybody have a clue?
 
Last edited:

jw00dy

Verified User
Joined
Dec 6, 2004
Messages
367
Location
Utah, USA
I don't... I hit my head on this for about 3 hours earlier and couldn't make heads or tails of it... Thank goodness for this forum because their are some very very smart cookies on here.
 

rohit

Verified User
Joined
Mar 20, 2007
Messages
210
Location
Melbourne
timm,

check the HTML::parser version

#perl -MHTML::parser -e 'print "$HTML::parser::VERSION\n"'

Since you did get to install HTML::parser 3.56 on CentOS then it seems like that the error is OS dependent.

Could be the install of HTML::parser 3.56 on your server didn't went well. Try 3.55 and keep the the below line commented in /usr/local/directadmin/scripts/spam.sh file

downloadMake $PARSER_NAME
and run the update.script again for SpamAssassin.
 

rohit

Verified User
Joined
Mar 20, 2007
Messages
210
Location
Melbourne
I also did install Mail::SPF as well and will recompile SpamAssassin. I'll post if I find something.
 

rohit

Verified User
Joined
Mar 20, 2007
Messages
210
Location
Melbourne
It worked again and now it only complains abt these modules

optional module missing: IP::Country
optional module missing: Razor2
optional module missing: Net::Ident
optional module missing: IO::Socket::INET6
optional module missing: Compress::Zlib
optional module missing: Mail::DomainKeys
optional module missing: Mail::DKIM
optional module missing: Archive::Tar
optional module missing: IO::Zlib
optional module missing: Encode::Detect

Here is an entry from /var/log/maillog

spamd: server started on port 783/tcp (running version 3.2.0)
 

Timmm

Verified User
Joined
Sep 12, 2005
Messages
36
Location
Amsterdam, The Netherlands
Rohit,

Thanks.... the cause: commented out the wrong line in spam.sh! I think i wasn't fully awake....

I Think i will also install some other modules...

Compiled on CentOS with parser 3.56 succesfully....
 

bigboy

Verified User
Joined
Nov 25, 2005
Messages
231
Location
USA
FreeBSD 5.x this error when start spamd i need fix this


mars# /usr/bin/spamd -d -c -m 5
[20017] info: config: score: the non-numeric score (.85) is not valid, a numeric score is required
[20017] info: config: SpamAssassin failed to parse line, "MY_DSL .85" is not valid for "score", skipping: score MY_DSL .85
[20017] info: config: score: the non-numeric score (.25) is not valid, a numeric score is required
[20017] info: config: SpamAssassin failed to parse line, "AOL_DSL .25" is not valid for "score", skipping: score AOL_DSL .25
[20017] info: config: score: the non-numeric score (.75) is not valid, a numeric score is required
[20017] info: config: SpamAssassin failed to parse line, "SARE_FROM_SPAM_WORD3 .75" is not valid for "score", skipping: score SARE_FROM_SPAM_WORD3 .75
[20017] info: config: score: the non-numeric score (.43) is not valid, a numeric score is required
[20017] info: config: SpamAssassin failed to parse line, "SALES_REPLY .43" is not valid for "score", skipping: score SALES_REPLY .43
 

CoolZero

Verified User
Joined
Jul 6, 2006
Messages
83
What you see is that there are some missing optional components.

Just do this on your commmand line:

Code:
cpan

if you get questions, just auto install everything.

Then,

install MODULENAME

Example:

install IP::Country
Please note that for Razor2 you need to download it from their website and install that by hand.

Also a note to the developers of Direct Admin. You need to change your scripts also. They have made some major changes and using new module names like Mail::SPF instead of Mail::SPF::Query. So I urge all users to wait to upgrade, or check it all by hand doing this with Cpan.
 
Last edited:

rohit

Verified User
Joined
Mar 20, 2007
Messages
210
Location
Melbourne
John

As I mentioned in my previous post that compiling HTML::parser 3.56 on redhat enpterprise 3.0 gives error. So it will break the spam.sh

PARSER_VER=3.56 in spam.sh
 

jw00dy

Verified User
Joined
Dec 6, 2004
Messages
367
Location
Utah, USA
Is their any particular reason all the perl modules that this uses are out of date, e.g., HTML::parser & Mail::SPF?
 

rohit

Verified User
Joined
Mar 20, 2007
Messages
210
Location
Melbourne
Just found out that the reason why HTML::parser 3.56 wont compile on RHEL 3.0 is because of the version of Perl 5.8.0 as this is what is installed on the box

READ from below.

http://groups.google.com/group/comp.lang.perl.modules/browse_thread/thread/9a899f8db1799348

Is there is an easier way to upgrade PERL in Enterprise Edition, without breaking anything as I know it can cause some issues as we need to make sure all the other relevant Perl Modules also need to be upgraded.
 

jw00dy

Verified User
Joined
Dec 6, 2004
Messages
367
Location
Utah, USA
I've noticed this on my CentOS 3 (RHEL3) box as well because I've tried to update perl, and it does, but it doesn't remove the 5.8.0 stuff it just creates another directory for the 5.8.8 stuff :(

I haven't a clue how to update it either so it only has 5.8.8 but I'll get to searching.
 

jw00dy

Verified User
Joined
Dec 6, 2004
Messages
367
Location
Utah, USA
hmmm, looks like I'd have to remove rpm -e all the centos3 Perl RPM's then start over. Not sure I'm daring enough to do that. Not on a remote machine that's 3000 miles away anyway.

ahh well, I can also see that the version numbers don't change, they are just back patched. My spamassassin works just fine though, so I'm not sure why I'm worrying.
 

AleSSaNDRo

Verified User
Joined
Nov 19, 2004
Messages
143
Location
Milano(Italy)
Code:
>/usr/bin/spamd -d -c -m 5
[8727] warn: server socket setup failed, retry 1: spamd: could not create INET socket on 127.0.0.1:783: Address already in use
[8727] warn: server socket setup failed, retry 2: spamd: could not create INET socket on 127.0.0.1:783: Address already in use
[8727] error: spamd: could not create INET socket on 127.0.0.1:783: Address already in use
spamd: could not create INET socket on 127.0.0.1:783: Address already in use
:(



EDIT: resolved with reboot ;)
 
Last edited:
Top