Spamassassin install failed: GET 3.3 request faild

IceHosting

Verified User
Joined
Oct 6, 2004
Messages
20
Location
Netherlands
Hello,

I try to install spamassassin, and I followed the tutorial from:
http://help.directadmin.com/item.php?id=36

I installed the cpan modules, that seems to go fine. But when I go to /usr/local/directadmin/scripts/ to run spam.sh I get the following error:

[...]-DCONTACT_ADDRESS="the administrator of that system" -m644 -Irules -O/usr/share/spamassassin user_prefs.template languages sa-update-pubkey.txt
chmod 755 /usr/share/spamassassin
http: GET 3.3 request failed: 400 URL must be absolute: 400 URL must be absolute
error: no mirror data available for channel updates.spamassassin.org
channel: MIRRORED.BY contents were missing, channel failed


run:
/usr/bin/spamd -d -c -m 15
Starting spamd doesnt work offcourse, also sa-update gives the same error as above.

Anybody an idea what the error could be? Is the spamassassin updates mirror down?

System details:
Centos 6 x64 minimal
Fresh install of directadmin

Tested also on another system; had exactly the same error.
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,447
It is now possible to install SpamAssassin using custombuild, so I think the article you link to need to be updated. To install SpamAssassin using custombuild, do this:

Code:
cd /usr/local/directadmin/custombuild
./build set spamassassin yes
./build update
./build versions
./build spamassassin
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,907
Hello,

We've seen a string of emails about this within the last week.
Since we've not changed anything recently, my guess is that it's a change on the download server end..

However, I did find this:
http://www.directadmin.com/forum/showthread.php?t=37777&page=1

Which may indicate that it's related to IPv6, if your network doesn't support it.
It's possible that a remote dns change to the download server (spamassasin.org) was changed in a manner that is breaking the install for box that have IPv6, but don't support it.

Post #14 mentions how to shut off IPv6 if you don't need it (I've not tested it, nor confirmed that it's a working solution, but his reply might indicate that it does fix it)

So if anyone does try it and it does fix the issue, please let us know!

John
 

vancanneyt

Verified User
Joined
Dec 13, 2012
Messages
77
I had the same issue on my new server i set up last weekend.
sa-update fails to get the latest spamassassin rules set so the installation fails.
This is how i solved it:
download the ruleset to your server through wget (get the rules from spamassassin.org), make sure you also download GPG, MD5 and SHA1 signature files
Mail-SpamAssassin-rules-3.3.2-r1104058.tar.gz
Mail-SpamAssassin-rules-3.3.2-r1104058.tgz.asc
Mail-SpamAssassin-rules-3.3.2-r1104058.tgz.md5
Mail-SpamAssassin-rules-3.3.2-r1104058.tgz.sha1
in ssh command:
sa-update --install Mail-SpamAssassin-rules-3.3.2-r1104058.tgz

this wll install the ruleset; when you build spamassassin again (./build spamassassin), no errors will turn up (that was the case on my server).

hope this solves your issue too.
 
Top