suPHP doesn't seem to be working!

justahost

Verified User
Joined
Mar 19, 2006
Messages
128
Hi guys.

Installed suPHP via Custombuild and all went well so I thought.
I moved an account from an old server to the new server I have set up which included a Gallery install.

The main gallery directory was set to 755, but would not work until I set it to 777.

Of course, I don't want 777 permissions so could anyone suggest why suPHP hasn't kicked in to prevent this happening?

Cheers
RY
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,331
Location
LT, EU
So, it's working :) You just don't know how to use it. It couldn't have 777 because it's very insecure. If you like to have an insecure server - just allow that in /usr/local/suphp/etc/suphp.conf. Good luck! If I didn't understand your problem correctly - check your .htaccess file.
 

justahost

Verified User
Joined
Mar 19, 2006
Messages
128
Sorry - its early on a SUnday morning so probably didn't write down what I meant!

I DO NOT want 777 as, like you say, its highly insecure so thats why I installed suPHP using ./build suphp.

What I wanted to know was:

I had no errors coming back from the build suphp command so thought everything was installed fine, but I think I may have forgotten a step as I can still set directories to 777 and suPHP doesn't give the 500 error I would of expected.

So, if anyone could give me a pointer at what to check to make sure suPHP is running properly and not allow 777 permissions I would be grateful!

Hope that makes it a bit clearer?!

Ry

EDIT: AFter you mentioned the conf file, I tool a look at /etc/httpd/conf/extra/httpd-suphp.conf and the file is empty if that matters!
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,331
Location
LT, EU
You don't need to do "./build suphp" :) It's just used to update it. "./build suphp" is run automatically together with "./build php n" (and you must do it when you set php5_cgi=yes in the options.conf). So, did you run "./build php n"?
 

justahost

Verified User
Joined
Mar 19, 2006
Messages
128
You don't need to do "./build suphp" :) It's just used to update it. "./build suphp" is run automatically together with "./build php n" (and you must do it when you set php5_cgi=yes in the options.conf). So, did you run "./build php n"?
You are a star.
I had forgotten to rebuild PHP!!

Thats the only trouble with the datacentre building DA - not 100% sure what they have done.

I did ask if they would let me install so I can use a checksheet but they went ahead and did it their on way!

Thanks again.

Happy to have a more secure server again!
 
Top