Troubles Let offering server hostname SSL cert instead of user domain SSL cert

mediacs

New member
Joined
Dec 11, 2019
Messages
10
I'm having troubles getting LE certificates setup in directadmin:
my vps provider said I first had to add this to my directadmin.conf to enable let's encrypt:

SSL=1
carootcert=/usr/local/directadmin/conf/carootcert.pem
force_hostname=server.mediacs.nl
ssl_redirect_host=server.mediacs.nl
enable_ssl_sni=1
mail_sni=1
letsencrypt=1


And then use this command (so that the cert doesnt get assigned to 'localhost'):

cd /usr/local/directadmin/scripts
./letsencrypt.sh request_single server.jedomein.nl


Then I assigned LE certificates to the individual the user domains

After that I get a SSL lock in the address bar when logged server.mediacs.nl:2222.
That's nice, but I really just want the SSL for the user domains (mediacs.nl, leveninbeeld.com, akoesta.rocks) to work out, and they don't (see attachment).
 

Attachments

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,934
Location
GMT +7.00
You should configure IPv6 correct on your server. There is no issue with certificates over IPv4, and the issue is reported only over IPv6. It might be because you don't have IPv6 assigned to your users domains in Apache, but have the IPv6 records in DNS.

At admin level link IPv6 to IPv4:

- https://www.directadmin.com/features.php?id=1377
 

mediacs

New member
Joined
Dec 11, 2019
Messages
10
Thanks, I don't see any warnings using the sslshopper tool, that's strange.
I checked IP management, the ip6 address was there. I can only asign 'admin' (admin user) there, and when I do it puts admin in the reseller column.
I also added a screenshot with the DNS settings of my vps provider, I use their nameservers.
 

Attachments

Top