Unable to receive emails ("authentication required")

zurih

Verified User
Joined
Jun 26, 2006
Messages
23
Hey guys
I have a problem receiving emails.
I'm able to send emails though.

I'm sending a test mail from a Gmail account.

In Gmail I get this:
Code:
Delivery to the following recipient failed permanently:

    xxx@xxx.co.il

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550 authentication required (state 14).
When I view /var/log/exim/rejectlog I have this:
Code:
2011-12-06 11:18:58 H=mail-fx0-f41.google.com [209.85.161.41] F=<xxx@gmail.com> rejected RCPT <xxx@xxx.co.il>: authentication required
I checked if it's an iptables issue by stopping it, and it didn't help.
Any idea?

Thank you
 

NoBaloney2

NoBaloney Internet Svcs.
Joined
Jun 17, 2007
Messages
498
Location
California
Can also be caused if for some reason the server thinks the domain's email isn't served on the server. Check MX Records entry in DirectAdmin login for the user, to make sure that the X is there.

Jeff
 

zurih

Verified User
Joined
Jun 26, 2006
Messages
23
Can also be caused if for some reason the server thinks the domain's email isn't served on the server. Check MX Records entry in DirectAdmin login for the user, to make sure that the X is there.

Jeff
That was it :)
Cheer !
 

synergy

Verified User
Joined
Nov 8, 2003
Messages
48
Location
Australia
I know I'm bumping an old thread (and probably stating the obvious but just in case it helps someone else) I had the same problem due to an oversight on my part. I had a domain hosted on my server, but their mail was external, so I had removed their domain from /etc/virtual/domains. Recently they changed their MX record back to my server, but I forgot to recreate the /etc/virtual/domains entry and was getting the same error. Adding the entry back to the domains file fixed mail delivery for their domain.
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
And just so you know: that's exactly what the checkmark does; it adds/deletes the domain name from /etc/virtual/domains.

Jeff
 

Djunity

Verified User
Joined
Mar 9, 2008
Messages
243
Location
Holland
I know I'm bumping an old thread (and probably stating the obvious but just in case it helps someone else) I had the same problem due to an oversight on my part. I had a domain hosted on my server, but their mail was external, so I had removed their domain from /etc/virtual/domains. Recently they changed their MX record back to my server, but I forgot to recreate the /etc/virtual/domains entry and was getting the same error. Adding the entry back to the domains file fixed mail delivery for their domain.
Had the same problem to this is the solution
 

Tpark

Verified User
Joined
Nov 2, 2018
Messages
18
Sorry for bumping an old thread,
I had this problem but with different solution:

1- Go to User Panel -> domain.com -> MX Records
2- Make Sure "Use this server to handle my e-mails. If not, change the MX records and uncheck this option." is Checked.
Done.

Some users are so Curious and check/uncheck everywhere.

SIB
 
Top