Upgrade OpenSSL (ports)

floris

Verified User
Joined
Oct 23, 2005
Messages
94
Hi,

What would be a good way to upgrade openssl on a FSBD 6.1 machine? I tried the following but got nowhere:

1. vi /etc/make.conf
WITH_OPENSSL_PORT=yes
WITH_OPENSSL_BETA=yes
2. cd /usr/ports/security/openssl

3. make install clean

4. cd /usr/local/directadmin/customapache

5. vi build
SSL_BASE="/usr/local" \
6. ./build update && ./build clean

7. ./build apache_ap2

This resulted in a bunch of errors

/usr/include/openssl/err.h:289: error: redefinition of typedef 'ERR_FNS'
/usr/local/include/openssl/ossl_typ.h:152: error: previous declaration of 'ERR_FNS' was here
So, this obviously is not correct. But where did i go wrong?
 

bigboy

Verified User
Joined
Nov 25, 2005
Messages
231
Location
USA
cannot upgrade openssl-0.9.8c

portsnap fetch
portsnap extract
portnsap update
cd /usr/ports/security/openssl
make install clean



mars# openssl version
OpenSSL 0.9.7e 25 Oct 2004
 

floris

Verified User
Joined
Oct 23, 2005
Messages
94
Two options here:

1)
vi /usr/local/etc/pkgtools.conf
MAKE_ARGS = {
'security/openssl' => '-DOPENSSL_OVERWRITE_BASE'
}


portinstall openssl
or 2)

cvsup stable-supfile

cd /usr/src

mergemaster -p

make buildworld
make buildkernel KERNCONF=KERNNAME
make installworld
make installkernel KERNCONF=KERNNAME

mergemaster

reboot
 

bigboy

Verified User
Joined
Nov 25, 2005
Messages
231
Location
USA
mars# portinstall openssl
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... /var/db/pkg/pkgdb.db: unexpected file type or format -- Invalid argument; rebuild needed] [Rebuilding the pkgdb <format:bdb_btree> in /var/db/pkg ... [Updating the portsdb <format:bdb_btree> in /usr/ports ... - 15699 port entries found .........1000.........2000.........3000.........4000.........5000.........6000.........7000.........8000.........9000.........10000.........11000.........12000.........13000.........14000.........15000...... ..... done]
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... /var/db/pkg/pkgdb.db: unexpected file type or format -- Invalid argument; rebuild needed] [Rebuilding the pkgdb <format:bdb_btree> in /var/db/pkg ... /usr/local/lib/ruby/site_ruby/1.8/pkgdb.rb:323:in `deorigin': /var/db/pkg/pkgdb.db: unexpected file type or format -- Invalid argument: Cannot update the pkgdb!]: Cannot update the pkgdb!] (PkgDB::DBError)
from /usr/local/sbin/portinstall:633:in `main'
from /usr/local/sbin/portinstall:632:in `each'
from /usr/local/sbin/portinstall:632:in `main'
from /usr/local/lib/ruby/1.8/optparse.rb:1254:in `call'
from /usr/local/lib/ruby/1.8/optparse.rb:1254:in `order!'
from /usr/local/lib/ruby/1.8/optparse.rb:1205:in `catch'
from /usr/local/lib/ruby/1.8/optparse.rb:1205:in `order!'
from /usr/local/lib/ruby/1.8/optparse.rb:1196:in `order'
from /usr/local/sbin/portinstall:528:in `main'
from /usr/local/lib/ruby/1.8/optparse.rb:755:in `initialize'
from /usr/local/sbin/portinstall:210:in `new'
from /usr/local/sbin/portinstall:210:in `main'
from /usr/local/sbin/portinstall:1981
 

bigboy

Verified User
Joined
Nov 25, 2005
Messages
231
Location
USA
venus# portinstall openssl
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 78 packages found (-0 +1) . done]
** Detected a package name change: openssl (security/openssl) -> 'openssl-overwrite-base' (security/openssl)
** No need to upgrade 'openssl-0.9.8c' (>= openssl-overwrite-base-0.9.8c). (specify -f to force)
 

bigboy

Verified User
Joined
Nov 25, 2005
Messages
231
Location
USA
show this version OpenSSL 0.9.7e-p1 not version openssl-0.9.8c

venus# openssl version
OpenSSL 0.9.7e-p1 25 Oct 2004
 
Last edited:
Top