user name limit

Invader Zim

Verified User
Joined
Sep 4, 2004
Messages
155
So I bought directadmin. $300 seems like a pretty fair price for such a package.

Until I noticed that usernames (for the hosting clients at least) cannot exceed 10 characters in length (docs say 8, but you can type up to 10). Now, I'd rather have my clients user names be the same as their domain name, seeing as a few of them have names that are pretty similar. And I would hate to abbreviate their names.

Now, FreeBSD's shell user names can exceed this length set in directadmin. How can I change this?
 

BigWil

Verified User
Joined
Aug 5, 2004
Messages
313
Zim,

vi /usr/local/directadmin/conf/directadmin.conf

change the max_username_length variable to 14 which is the max allowed by DA so far.

max_username_length=14

I would prefer 16 which is what I am used to but hey... shouldn't be too hard to live with.

Big Wil
 

BigWil

Verified User
Joined
Aug 5, 2004
Messages
313
Yep... that 10 character limit was one of the first items that shocked the hell out of me too.

Remember that this was initially written for Linux so there will be some stuff to get used to as it is adjusted and small compromises made so it will work on both OS platforms.

Big Wil
 

Invader Zim

Verified User
Joined
Sep 4, 2004
Messages
155
Well, I changed the setting in the config file, but it still won't let me type more than 10 characters. I did the directadmin restart thing after I noticed directadmin reload didn't work, but still, nothing.

Haven't tried stopping directadmin and then manually starting it (which brings me to a point: why is there a start link in the webinterface of directadmin? it's not like you can start it from the directadmin interface when the interface is not running, right?), but I will soon, after I go to bed and catch up on some sleep.

And no, I'm not rebooting the server, that's a windows solution.
 

BigWil

Verified User
Joined
Aug 5, 2004
Messages
313
Did you add the max_username_length=14 string or did you revise the one that was already in there. Could have two if you just added it in.

Be sure to restart Directadmin properly:

/usr/local/etc/rc.d/directadmin restart

Big Wil
 

Invader Zim

Verified User
Joined
Sep 4, 2004
Messages
155
I revised the one that was already present. I restarted directadmin thru the webinterface. Will try the manual restart tho.
 

BigWil

Verified User
Joined
Aug 5, 2004
Messages
313
Do a search for any other directadmin.conf files on the system. I had two and changed it in both. DA has a few files that have precedence over one another. Maybe that is what we are experiencing here. But I thought the one under conf/ was the one with all the precedence. It would be good to know.

Big Wil
 
Top