webapps not working again

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
635
I give up on this I guess, nginx on DA is really not ready.
all webapps are a 502 error again after doing php update.
I can do a ./build rewrite_confs and get them working then hand edit the user nginx conf files as all rewrite rules (friendly urls, added modules like flv and mp4, etc) get overwritten.
anytime I add or remove a domain I need to deal with this.
sad as nginx works much better when getting slammed with users on sites.

oh well, I am done.
not worth the continuous hassles that cpanel/ispconfig panels don't have with nginx setups.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,477
Location
LT, EU
We did not tell anywhere that nginx for DA is stable. It's still alpha. Your issue seems to be related to PHP-FPM, please post the contents of /usr/local/php5*/etc/php-fpm.conf. I think you have low request_terminate_timeout set there. Please also check /usr/local/php5*/var/log/php-fpm.log and /var/log/nginx/error_log. Thank you.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
635
can't now as I swapped to apache and deleted nginx/php-fpm stuff.

and we've already gone through those.
 
Last edited:

DA DUDE

New member
Joined
Jul 4, 2013
Messages
10
I give up on this I guess, nginx on DA is really not ready.
all webapps are a 502 error again after doing php update.
I can do a ./build rewrite_confs and get them working then hand edit the user nginx conf files as all rewrite rules (friendly urls, added modules like flv and mp4, etc) get overwritten.
anytime I add or remove a domain I need to deal with this.
sad as nginx works much better when getting slammed with users on sites.

oh well, I am done.
not worth the continuous hassles that cpanel/ispconfig panels don't have with nginx setups.

Please run
Code:
ls -l /usr/local/php54/sockets/webapps.sock
. If you do NOT get
Code:
srw-rw---- 1 webapps nginx 0 Date / Time /usr/local/php54/sockets/webapps.sock
then you need to run
Code:
chown webapps:nginx /usr/local/php54/sockets/webapps.sock
. You need to run these with nginx and not apache.
 

dmacleo

Verified User
Joined
Jun 21, 2012
Messages
635
already did all tha, thanks though.
made no difference for me.
installed cpanel saturday.
 

DA DUDE

New member
Joined
Jul 4, 2013
Messages
10
already did all tha, thanks though.
made no difference for me.
installed cpanel saturday.
I was able to get it to work on the first try. If you are willing to give it another go we can continue to troubleshoot.
 
Top