When adding an IPv6 address to an domain in domain setup, DNS records are not created

sfxdana

Verified User
Joined
Feb 22, 2007
Messages
9
When adding an IPv6 address to an domain in domain setup, IPv6 DNS records are not created

Tested this with evolution, no DNS entries added for the IPv6 address.

Switched back to Enhanched, removed the IPv6 address and then added the IPv6 again now the IPv6 DNS records are added.

Axel

Running Directadmin 1.57.0
 
Last edited:

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,206
Location
LT, EU
The problem has been solved. Thank you for the report! Please run the following commands to update the skin:
Code:
cd /usr/local/directadmin/data/skins
mkdir evolution
cd evolution
wget -O evolution.tar.gz https://demo.directadmin.com/download/evolution.tar.gz
tar xvzf evolution.tar.gz
cd ..
chown -R diradmin:diradmin evolution
Thank you!
 

sfxdana

Verified User
Joined
Feb 22, 2007
Messages
9
Thanks, DNS records are now created.

But there are still some small issues.

When deleting the IPv6 address your are not able to select "Remove DNS records for IP ", same thing with an IPv4 address.

And when you delete the IP(s), the page isn't updated, so you have to refresh, or press back and go back to assigned IP's, before you are able to add the IPv6 again.

But these are less of a problem. And can be worked around. But would be nice if it can be fixed in some version.

Regards,

Axel.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,206
Location
LT, EU
It's been fixed in latest version of the skin. Thank you for the report!
 
Top