Why I can not get email score 10/10 for my email?

Tommyhara

Verified User
Joined
Jul 25, 2014
Messages
167
Why I am getting this error testing with mail-tester .com

and its alearing that:

Your DKIM signature is not valid

My score is just 6.7/10 and I can get it 10/10

I have already got _dmarc, spf, DKIM on my Directadmin

I have same problem on cPanel.

but on Plesk control panel, it is easy to get 10/10 with mail-tester for my email

What things would you suggest to check and fix this problem?

Thanks
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,046
Location
Maastricht
The error says your DKIM signature is not valid. So you have to look there first.

If I do a test with my company email resided on a DA server I get a 10/10 score.

You did everything the helpfile said?
https://help.directadmin.com/item.php?id=569

Or maybe you need to do the DNS record for DKIM different on DA and Cpanel then you do on Plesk.
I use these 2 in DNS:
Code:
_domainkey	TXT	"o=~"
and
Code:
x._domainkey	TXT	"v=DKIM1; k=rsa; p=M...etc
exactly like that with the underscores and dots.
 
Last edited:

Tommyhara

Verified User
Joined
Jul 25, 2014
Messages
167
Thanks Richard!

I found the reason, because I used SSL thus I pointed to extra IP address for DKIM on DNS settings and now i can verify it at 9/10 on mail-tester.

it is a bit strange because
I have not added .include_if_exists /etc/exim.dkim.conf to /etc/exim.conf
and I tried to find the file /etc/exim.dkim.conf but didn't see it there.

and these commands

cd /usr/local/directadmin
cp -f conf/directadmin.conf

I checked directadmin.conf and didn't see dkim=1 there but dkim is enabled on my server.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,046
Location
Maastricht
I have not added .include_if_exists /etc/exim.dkim.conf to /etc/exim.conf
This is not needed if you are using the spamblocker exim.conf 4.x (4.5.4 right now if I'm correct). It has an "if exist" setting by default.
So that might be the reason that you did not have to make that setting yourself.

However it is odd that you don't have the exim.dkim.conf, did you forget to do step 2?
https://help.directadmin.com/item.php?id=569
 
Top