Magento 2 + PHP 7 + Opcache & APCu

webunity

Verified User
In the past i've compiled APCu 4.0.6.1 from source and installed it on my server. I am migrating to PHP-FPM 7.x for my new server setup and i was wondering if there is a possibility to install APCu on PHP7. Reason i am asking is because i see conflicting messages; On the one hand i see that APC is dead, on the other hand i see that i have to install a backwards compatibility layer;

- https://serverpilot.io/docs/how-to-install-the-php-apcu-extension
- https://serverpilot.io/docs/how-to-install-the-php-apcu-bc-extension
- https://github.com/krakjoe/apcu-bc

Both opcache & APCu are advised for Magento 2, which is the root cause of my question.

(note; i am assuming opcache setting in custombuild is compatible with php-fpm on PHP 7, since i am also installing that)
 
Last edited:
Top