OpenSSL could not be find by any installation

JohnnyBravo

Verified User
Hi,

I'm trying to install nginx as a reverse_proxy.
I've installed Openssl by yum

openssl.x86_64 1:1.0.2k-12.el7 @base
openssl-devel.x86_64 1:1.0.2k-12.el7 @base
openssl-libs.x86_64 1:1.0.2k-12.el7 @base
openssl-perl.x86_64 1:1.0.2k-12.el7 @base
openssl-pkcs11.x86_64 0.4.7-7.el7 @epel

But the nasty thing is... that custombuild can't find the OpenSSL library.
After ./build nginx I get the following error:

Trying to make Nginx...
make -f objs/Makefile
make[1]: Entering directory `/usr/local/directadmin/custombuild/nginx-1.14.0'
cd /usr/include/openssl \
&& if [ -f Makefile ]; then make clean; fi \
&& ./config --prefix=/usr/include/openssl/.openssl no-shared no-threads \
&& make \
&& make install_sw LIBDIR=lib
/bin/sh: line 2: ./config: No such file or directory
make[1]: *** [/usr/include/openssl/.openssl/include/openssl/ssl.h] Error 127
make[1]: Leaving directory `/usr/local/directadmin/custombuild/nginx-1.14.0'
make: *** [build] Error 2

*** The make has failed, would you like to try to make again? (y,n):
n

I've tried Google so hard, but can't find a solution.
 

zEitEr

Super Moderator
Hello,

Do you try to install nginx against another OpenSSL version?

Check /usr/local/directadmin/custombuild/custom/nginx_reverse/configure.nginx for

Code:
--with-openssl=
you might need either remove the line or unpack OpenSSL source filers into the specified folder.
 

JohnnyBravo

Verified User
Thanx for your reply zEitEr,

Yes I did with Openssl version 1.1.0i, and the installation of Nginx worked out fine, but the installation of nginx_apache delivered some errors.
Anyways I've solved the problem by setting back the system to an earlier moment by using my backup.

Kind regards,

Hindrik
 
Top