build Clamav Error

savas

Verified User
Joined
Jul 20, 2020
Messages
7
Hello trying to install ClamAV to Centos 8 / D.A.
cd /usr/local/directadmin/custombuild
./build update
./build set clamav yes
./build clamav
and getting:
Code:
Error:
 Problem 1: conflicting requests
  - nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-0.103.7-1.el8.x86_64
 Problem 2: package clamd-0.103.7-1.el8.x86_64 requires libclamav.so.9()(64bit), but none of the providers can be installed
  - package clamd-0.103.7-1.el8.x86_64 requires libclamav.so.9(CLAMAV_PUBLIC)(64bit), but none of the providers can be installed
  - package clamd-0.103.7-1.el8.x86_64 requires libclamav.so.9(CLAMAV_PRIVATE)(64bit), but none of the providers can be installed
  - package clamd-0.103.7-1.el8.x86_64 requires clamav-lib = 0.103.7-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-lib-0.103.7-1.el8.x86_64
 Problem 3: package clamav-update-0.103.7-1.el8.x86_64 requires libclamav.so.9()(64bit), but none of the providers can be installed
  - package clamav-update-0.103.7-1.el8.x86_64 requires libclamav.so.9(CLAMAV_PUBLIC)(64bit), but none of the providers can be installed
  - package clamav-update-0.103.7-1.el8.x86_64 requires libclamav.so.9(CLAMAV_PRIVATE)(64bit), but none of the providers can be installed
  - package clamav-update-0.103.7-1.el8.x86_64 requires clamav-lib = 0.103.7-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides libjson-c.so.4(JSONC_0.14)(64bit) needed by clamav-lib-0.103.7-1.el8.x86_64
: Any solution to fix?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,744
Location
GMT +7.00
Hello,

Try and update OS first with yum update and then repeat it again.
 

Active8

Verified User
Joined
Jul 13, 2013
Messages
1,342
Im using what im using
It makes no sense to pull an dead horse, like @jamgames2 suggest its wise to drop EOL software otherwise you will face problems.
There is an upgrade script that upgrades your Centos8 to Almalinux (or Rockylinux) 8 without worries.
If your programs works with Centos8 you can safely update to other system as well
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,744
Location
GMT +7.00
Im using what im using :) and looking solution to fix the problem no afense...

There is no solution for CentOS 8, unless you compile ClamAV from sources. The OS should be updated as already mentioned earlier here.
 
Top