CustomBuild 2.0 / php 7.4 & 8.0 failing

td204

New member
Joined
Oct 22, 2020
Messages
2
Hi there!
I am trying to set php 7.4 as 2nd php_release and 8.0 as 4th release.
But both builds are failing. php 7.3 and 7.2 are working fine.

Context / versions / config
Code:
[[email protected] custombuild]# ./build version
2.0.0 (rev: 2577)

[[email protected] custombuild]# lsb_release -a
Distributor ID:    CentOS
Description:    CentOS release 6.10 (Final)
Release:    6.10

[[email protected] custombuild]# cat options.conf 
#PHP Settings
php1_release=7.3
php1_mode=mod_php
php2_release=7.4
php2_mode=php-fpm
php3_release=7.2
php4_release=no
php3_mode=php-fpm
php4_mode=php-fpm
php_ini=no
php_timezone=Europe/Amsterdam
php_ini_type=production
x_mail_header=yes

Output after building:
Code:
[[email protected] custombuild]# ./build php_expert 7.4 php-fpm
main/internal_functions_cli.lo sapi/litespeed/lsapi_main.lo sapi/litespeed/lsapilib.lo -lcrypt -lresolv -lcrypt -lrt -lstdc++ -liconv -lrt -lm -ldl -lrt -lxml2 -lkrb5 -lk5crypto -lgssapi_krb5 -lssl -lcrypto -lsqlite3 -lz -lcurl -lssl -lcrypto -lxml2 -lssl -lcrypto -lz -lpng16 -lz -lwebp -ljpeg -lfreetype -licuio -licui18n -licuuc -licudata -lonig -lsqlite3 -lxml2 -lxml2 -lsodium -lcrypt -lxml2 -lxml2 -lxml2 -lxslt -lz -liconv -lm -ldl -lrt -lxml2 -lexslt -lxslt -lz -liconv -lm -ldl -lxml2 -lzip -lz -lssl -lcrypto -lcrypt  -o sapi/litespeed/php
ext/intl/.libs/php_intl.o: In function `zm_shutdown_intl':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/php_intl.c:1000: undefined reference to `u_cleanup_58'
ext/intl/.libs/php_intl.o: In function `intl_locale_get_default':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/php_intl.c:120: undefined reference to `uloc_getDefault_58'
ext/intl/.libs/php_intl.o: In function `zm_info_intl':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/php_intl.c:1048: undefined reference to `ucal_getTZDataVersion_58'
ext/intl/.libs/intl_error.o: In function `intl_error_get_message':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/intl_error.c:140: undefined reference to `u_errorName_58'
ext/intl/.libs/intl_convert.o: In function `intl_convert_utf8_to_utf16':

<<<CUT CONTENTS>>>

ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::~CodePointBreakIterator()':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/breakiterator/codepointiterator_internal.cpp:76: undefined reference to `icu_58::UMemory::operator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTIN3PHP22CodePointBreakIteratorE[_ZTIN3PHP22CodePointBreakIteratorE]+0x10): undefined reference to `typeinfo for icu_58::BreakIterator'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xa8): undefined reference to `icu_58::BreakIterator::getRuleStatus() const'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xb0): undefined reference to `icu_58::BreakIterator::getRuleStatusVec(int*, int, UErrorCode&)'
collect2: error: ld returned 1 exit status
make: *** [Makefile:306: sapi/fpm/php-fpm] Error 1

I have tried all of the following already:
Code:
yum -y install cmake3
./build icu
./build php n
./build pcre

What else can I do?
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
2,994
Location
Murfreesboro
Is this a fresh install? Is it 64bit?
Did you double-check the pre-install cmds?
Code:
yum install wget tar gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio \
libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed \
autoconf automake libtool which patch mailx bzip2-devel lsof glibc-headers kernel-devel expat-devel db4-devel

what happens if you do
Code:
cd /usr/local/directadmin/custombuild
./build set_fastest
./build clean
./build update
./build all
./build rewrite_confs

does it fail?
 

td204

New member
Joined
Oct 22, 2020
Messages
2
Still no luck... 64bit, machine is already several years old.

Code:
[[email protected] custombuild]# yum install wget tar gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed autoconf automake libtool which patch mailx bzip2-devel lsof glibc-headers kernel-devel expat-devel db4-devel
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirrors.supportex.net
 * centos-sclo-rh: mirrors.supportex.net
 * centos-sclo-sclo: centos.mirror.transip.nl
 * epel: mirror.hostnet.nl
 * extras: mirrors.supportex.net
 * updates: centos.mirror.transip.nl
Package wget-1.12-10.el6.x86_64 already installed and latest version
Package 2:tar-1.23-15.el6_8.x86_64 already installed and latest version
Package gcc-4.4.7-23.el6.x86_64 already installed and latest version
Package gcc-c++-4.4.7-23.el6.x86_64 already installed and latest version
Package flex-2.5.35-9.el6.x86_64 already installed and latest version
Package bison-2.4.1-5.el6.x86_64 already installed and latest version
Package 1:make-3.81-23.el6.x86_64 already installed and latest version
Package 32:bind-9.8.2-0.68.rc1.el6_10.7.x86_64 already installed and latest version
Package 32:bind-libs-9.8.2-0.68.rc1.el6_10.7.x86_64 already installed and latest version
Package 32:bind-utils-9.8.2-0.68.rc1.el6_10.7.x86_64 already installed and latest version
Package openssl-1.0.1e-58.el6_10.x86_64 already installed and latest version
Package openssl-devel-1.0.1e-58.el6_10.x86_64 already installed and latest version
Package 4:perl-5.10.1-144.el6.x86_64 already installed and latest version
Package 1:quota-3.17-23.el6.x86_64 already installed and latest version
Package libaio-0.3.107-10.el6.x86_64 already installed and latest version
Package libcom_err-devel-1.41.12-24.el6.x86_64 already installed and latest version
Package libcurl-devel-7.19.7-54.el6_10.x86_64 already installed and latest version
Package gd-2.0.35-11.el6.x86_64 already installed and latest version
Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
Package zip-3.0-1.el6_7.1.x86_64 already installed and latest version
Package unzip-6.0-5.el6.x86_64 already installed and latest version
Package libcap-devel-2.16-5.5.el6.x86_64 already installed and latest version
Package cronie-1.4.4-16.el6_8.2.x86_64 already installed and latest version
Package bzip2-1.0.5-7.el6_0.x86_64 already installed and latest version
Package cyrus-sasl-devel-2.1.23-15.el6_6.2.x86_64 already installed and latest version
Package perl-ExtUtils-Embed-1.28-144.el6.x86_64 already installed and latest version
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
Package automake-1.11.1-4.el6.noarch already installed and latest version
Package libtool-2.2.6-15.5.el6.x86_64 already installed and latest version
Package which-2.19-6.el6.x86_64 already installed and latest version
Package patch-2.6-8.el6_9.x86_64 already installed and latest version
Package mailx-12.4-10.el6_10.x86_64 already installed and latest version
Package bzip2-devel-1.0.5-7.el6_0.x86_64 already installed and latest version
Package lsof-4.82-5.el6.x86_64 already installed and latest version
Package glibc-headers-2.12-1.212.el6_10.3.x86_64 already installed and latest version
Package kernel-devel-2.6.32-754.33.1.el6.x86_64 already installed and latest version
Package expat-devel-2.0.1-13.el6_8.x86_64 already installed and latest version
Package db4-devel-4.7.25-22.el6.x86_64 already installed and latest version
Nothing to do

Code:
cd /usr/local/directadmin/custombuild
./build set_fastest
./build clean
./build update
./build all

<SNAP>


ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::createBufferClone(void*, int&, UErrorCode&)':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/breakiterator/codepointiterator_internal.cpp:258: undefined reference to `icu_58::UMemory::operator new(unsigned long)'
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/breakiterator/codepointiterator_internal.cpp:258: undefined reference to `icu_58::UMemory::operator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::getUText(UText*, UErrorCode&) const':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/breakiterator/codepointiterator_internal.cpp:112: undefined reference to `utext_clone_58'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::~CodePointBreakIterator()':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/breakiterator/codepointiterator_internal.cpp:70: undefined reference to `icu_58::BreakIterator::~BreakIterator()'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::~CodePointBreakIterator()':
/usr/local/directadmin/custombuild/php-7.4.11/ext/intl/breakiterator/codepointiterator_internal.cpp:76: undefined reference to `icu_58::UMemory::operator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTIN3PHP22CodePointBreakIteratorE[_ZTIN3PHP22CodePointBreakIteratorE]+0x10): undefined reference to `typeinfo for icu_58::BreakIterator'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xa8): undefined reference to `icu_58::BreakIterator::getRuleStatus() const'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xb0): undefined reference to `icu_58::BreakIterator::getRuleStatusVec(int*, int, UErrorCode&)'
collect2: error: ld returned 1 exit status
make: *** [Makefile:348: sapi/phpdbg/phpdbg] Error 1
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
10,220
Location
LT, EU
I think ICU is just too old for 7.4/8.0. Make sure there are no other PHP versions lower than PHP 5.5 and it should start using new ICU then (and succeed with PHP 7.4/8.0). I'd also like to note CentOS6 is going to be end-of-life very soon.
 

yak983

Verified User
Joined
Oct 6, 2009
Messages
40
remove the old icu rpm from centos 6
libicu-4.2.1-15.el6_10.x86_64
libicu-devel-4.2.1-15.el6_10.x86_64

and retry
 
Top