Does directadmin no longer support the installation of MySQL 5.7?

calmok

Verified User
Joined
Aug 11, 2015
Messages
57
I'm in options Set mysql=5.7 in conf
Tips:
Incorrect mysql value (used to specify MySQL release) set in the options.conf file. Set: 5.7. Available values: 8.0.
 

realcryptonight

Verified User
Joined
Nov 16, 2019
Messages
391
It seems like it should still be allowed as it not (yet) on the removal list.

But I would really advice to use the latest version of MySQL if possible since EOL of 5.7 will also follow in october 2023. (And my guess is DirectAdmin will follow shortly after.)
 

jamgames2

Verified User
Joined
Aug 16, 2019
Messages
944
I suggest upgrade to mariadb with change some little config, so your all application will work like mysql 5.7

add some config to /etc/my.cnf

like this in under [mysqld] section
Code:
[mysqld]
sql_mode=""
 

primemeiq

New member
Joined
Jan 26, 2023
Messages
1
Same question. I Can't downgrade MySQL from 8.0 to 5.7 or even install it on fresh system (AlmaLinux 8.7).
It's possible to install 5.7 somehow?
 
Top