Reverse-proxy NGINX + Apache on Directadmin powered server with CB 2.x

thaidt

Verified User
Joined
May 6, 2019
Messages
16
I disable ipv6 with
nano /etc/sysctl.conf
added
Code:
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1

But not work, when i run again ./build nginx_apache
 

thaidt

Verified User
Joined
May 6, 2019
Messages
16
i was reboot vps.
I check ip a | grep inet6 then nothing.
i run command ./build nginx_apache then error again :(
How do I keep it from coming back?
 

MaXi32

Verified User
Joined
Jul 25, 2016
Messages
609
Location
The Earth
how do disable ipv6?
i have added net.ipv6.conf.all.disable_ipv6 = 1 to /etc/sysctl.conf

it is work? please help me

Code:
2021-09-26 22:43:28 (505 MB/s) - '/etc/logrotate.d/nginx' saved [186/186]

Sep 26 22:45:01 sv.nadigi.vn nginx[400598]: nginx: [emerg] bind() to [::1]:80 failed (99: Cannot assign requested address)
Sep 26 22:45:01 sv.nadigi.vn nginx[400598]: nginx: configuration file /etc/nginx/nginx.conf test failed
Sep 26 22:45:01 sv.nadigi.vn systemd[1]: nginx.service: Control process exited, code=exited status=1
Sep 26 22:45:01 sv.nadigi.vn systemd[1]: nginx.service: Failed with result 'exit-code'.
Sep 26 22:45:01 sv.nadigi.vn systemd[1]: Failed to start The nginx HTTP and reverse proxy server.

You need to add the following and recompile kernel:

Code:
echo "net.ipv6.ip_nonlocal_bind = 1" >> /etc/sysctl.conf
# Recompile kernel setting with this:
sysctl -p /etc/sysctl.conf

Make sure to have this too:

Code:
echo "net.ipv4.ip_nonlocal_bind = 1" >> /etc/sysctl.conf
# Recompile kernel setting with this:
sysctl -p /etc/sysctl.conf

Related to this documentation: https://docs.directadmin.com/webser...-80-failed-99-cannot-assign-requested-address

EDITED: I just read that you don't have IPv6, so the above might not work. Sorry.
 
Last edited:
Top