There is no ionCube loader available for PHP 8.1.

feerdispzoo

Verified User
Joined
Jan 17, 2022
Messages
74
[[email protected] ~]# cd /usr/local/directadmin/custombuild
[[email protected] custombuild]# ./build ioncube
Downloading ioncube_loaders_lin_x86-64.tar.gz...
######################################################################## 100.0%
There is no ionCube loader available for PHP 8.1.

CloudLinux + LiteSpeed Web Server.

In this case, can anyone help me what I should do, for install ioncube?
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
8,995
Location
Maastricht
In this case, can anyone help me what I should do, for install ioncube?
Either reverse to using PHP 7.x or wait a bit longer.

Because ioncube for php 8.x is not ready yet, hopefully end of this month.
 

priyansh

New member
Joined
Dec 10, 2021
Messages
2
Until ionCube is supported for PHP 8:
cd /usr/local/directadmin/custombuild
./build set php1_release 7.4
./build php n
./build set ioncube yes
./build ioncube
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
8,995
Location
Maastricht
some not too happy folks I can imagine.
They don't have to wait too long. Check the link I posted, it's updated:
Last Updated: 29th July 2022

29TH JULY UPDATE: Beta testing has progressed well and the roll-out procedure has started with website updates and packaging. Full release is expected next week.
So that would be this week.
 

feerdispzoo

Verified User
Joined
Jan 17, 2022
Messages
74
I see update:
5TH AUGUST UPDATE: Online Encoder has been updated with PHP 8.1 encoding support. Version 12.0.0 Loaders now available (Linux only for now, other operating systems will follow soon after).

I try using custom build after update, but still no avaialble this relase yet, It is possible say to DirectAdmin to upgrade this?

The second thing, I try download latest version with wget command from official website.
I see this, also from official website not available for php 8.1 in package.
 

Attachments

  • missing_8_1.png
    missing_8_1.png
    36.1 KB · Views: 16

Richard G

Verified User
Joined
Jul 6, 2008
Messages
8,995
Location
Maastricht

BTCTech

Member
Joined
Jul 20, 2022
Messages
52
As a developer i would wait on using PHP 8 until everything settles.

Like everything its best to gradaually update and replace functions when needed.
 

BTCTech

Member
Joined
Jul 20, 2022
Messages
52
Is there something specific you need in PHP 8.1 that 7.x cant do for you?
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
8,995
Location
Maastricht
Not for me.
But there are some people wanting to upgrade to php 8.x which is logical, but some applications require ioncube. So they can't upgrade until all is released and since php 7.4 is EOL and EOS end of november this year, it's quite logical they like to upgrade. ;)
 

eva2000

Verified User
Joined
Jul 1, 2019
Messages
105

Richard G

Verified User
Joined
Jul 6, 2008
Messages
8,995
Location
Maastricht
So they skipped PHP 8.0 support for 8.1 only!
Yes.

Will you be supporting PHP 8.0?
We will not be supporting PHP 8.0. Much like with our version 10 release, we decided early on to skip over the x.0 PHP release as those can tend to be incomplete but mainly because it allows us more time to work on things our end. PHP 8 support will come in version 12 starting with PHP 8.1.
 

lrdmafia

Verified User
Joined
Jun 30, 2020
Messages
34
I have php1_release 8.1 ,, how to switch to the latest version of ioncube? , it doesn't work with custom build,
 

Zhenyapan

Verified User
Joined
Feb 23, 2018
Messages
1,343
Location
UA
@lrdmafia
new archive has different structure, so:
or wait till DA repack it to same structure and make it install from their repo.
or you can install it manually.
 
Top