Activate Keep-Alive with NGINX-Apache

combicart

New member
Joined
Mar 16, 2016
Messages
3
Hello,

I've setup a new VPS with DirectAdmin. With custombuild i've setup Apache and Nginx reverse proxy with:
Code:
./build set webserver nginx_apache
Everything is working great so far. However when checking a website with e.g. GTMetrix, I get a very low score because the 'KeepAlive' option isn't active.

I've searched the forums, but I can't seem to find how to enable this with the Apache - NGINX setup.

Does anybody know how to activate the KeepAlive option?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,105
Location
GMT +7.00
Hello,

1. Copy /usr/local/directadmin/custombuild/configure/nginx_reverse/conf/nginx-defaults.conf

to

/usr/local/directadmin/custombuild/custom/nginx_reverse/conf/nginx-defaults.conf

2. Change

Code:
keepalive_timeout  0;
to

Code:
keepalive_timeout  15;
or whatever you want. And run:

Code:
./build rewrite_confs
 
Top