Apache no longer works after Debian upgrade

Mattie

Verified User
Joined
Jun 1, 2008
Messages
81
Hi,

I have just upgraded my server from Debian 8 to Debian 9. Just the standard upgrade && dist-upgrade and after that a rebuild and rewrite_conf for everything.

However when I try to access one of my sites I get the ERR_EMPTY_RESPONSE error.

The error log from apache only contains:
Code:
[Tue Nov 19 16:10:19.936516 2019] [core:notice] [pid 18069] AH00052: child pid 18140 exit signal Aborted (6)
And the debug mode is also not really usefull:
Code:
root@vps:/var/log/httpd# httpd -X -e trace8
[Tue Nov 19 16:11:12.663463 2019] [so:debug] [pid 18911] mod_so.c(266): AH01575: loaded module ruid2_module from /usr/lib/apache/mod_ruid2.so
[Tue Nov 19 16:11:12.664028 2019] [so:debug] [pid 18911] mod_so.c(266): AH01575: loaded module systemd_module from /usr/lib/apache/mod_systemd.so
[Tue Nov 19 16:11:12.664566 2019] [so:debug] [pid 18911] mod_so.c(266): AH01575: loaded module mpm_prefork_module from /usr/lib/apache/mod_mpm_prefork.so
[Tue Nov 19 16:11:12.676174 2019] [so:debug] [pid 18911] mod_so.c(266): AH01575: loaded module php7_module from /usr/lib/apache/libphp7.so
[Tue Nov 19 16:11:12.692410 2019] [auth_digest:debug] [pid 18911] mod_auth_digest.c(372): AH01757: generating secret for digest authentication
Aborted
Any ideas? I have disabled http2 in the da config file to make sure that is not the issues.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,331
Location
LT, EU
Disable mod_ruid2 there, switch php mode to any other.
 

Mattie

Verified User
Joined
Jun 1, 2008
Messages
81
Is that no longer supported? Then I can just switch to php-ftp to be also compatible with nginx if I decide to move to that.

edit:
changed to php-fpm, only needed to disable a phpinidir setting in a vhost but i will figure that out later :)
so far it seems to work, thanks!
 
Last edited:
Top