Auto setup failing after a very long pause between the MYSQL and PHP setup

darkus

Verified User
Joined
Dec 15, 2005
Messages
114
I've installed a few DA servers this week alone, and for some reason this one keeps failing

What I see is the following messages

PHP:
make[1]: Leaving directory `/usr/local/directadmin/custombuild/libiconv-1.15/po'
cd man && make install prefix='/usr/local' exec_prefix='/usr/local' datarootdir='/usr/local/share' datadir='/usr/local/share' mandir='/us                                                                              r/local/share/man'
make[1]: Entering directory `/usr/local/directadmin/custombuild/libiconv-1.15/man'
if [ ! -d /usr/local/share/man/man1 ] ; then /bin/sh ../build-aux/mkinstalldirs /usr/local/share/man/man1 ; fi
builddir="`pwd`"; cd . && for f in *.1 ; do (cd "$builddir"; echo /usr/bin/install -c -m 644 ./$f /usr/local/share/man/man1/$f ; /usr/bin                                                                              /install -c -m 644 ./$f /usr/local/share/man/man1/$f) ; done
/usr/bin/install -c -m 644 ./iconv.1 /usr/local/share/man/man1/iconv.1
if [ ! -d /usr/local/share/man/man3 ] ; then /bin/sh ../build-aux/mkinstalldirs /usr/local/share/man/man3 ; fi
builddir="`pwd`"; cd . && for f in *.3 ; do (cd "$builddir"; echo /usr/bin/install -c -m 644 ./$f /usr/local/share/man/man3/$f ; /usr/bin                                                                              /install -c -m 644 ./$f /usr/local/share/man/man3/$f) ; done
/usr/bin/install -c -m 644 ./iconv.3 /usr/local/share/man/man3/iconv.3
/usr/bin/install -c -m 644 ./iconv_close.3 /usr/local/share/man/man3/iconv_close.3
/usr/bin/install -c -m 644 ./iconv_open.3 /usr/local/share/man/man3/iconv_open.3
/usr/bin/install -c -m 644 ./iconv_open_into.3 /usr/local/share/man/man3/iconv_open_into.3
/usr/bin/install -c -m 644 ./iconvctl.3 /usr/local/share/man/man3/iconvctl.3
if [ ! -d /usr/local/share/doc/ ] ; then /bin/sh ../build-aux/mkinstalldirs /usr/local/share/doc/ ; fi
builddir="`pwd`"; cd . && for f in *.html ; do (cd "$builddir"; echo /usr/bin/install -c -m 644 ./$f /usr/local/share/doc//$f ; /usr/bin/                                                                              install -c -m 644 ./$f /usr/local/share/doc//$f) ; done
/usr/bin/install -c -m 644 ./iconv.1.html /usr/local/share/doc//iconv.1.html
/usr/bin/install -c -m 644 ./iconv.3.html /usr/local/share/doc//iconv.3.html
/usr/bin/install -c -m 644 ./iconv_close.3.html /usr/local/share/doc//iconv_close.3.html
/usr/bin/install -c -m 644 ./iconv_open.3.html /usr/local/share/doc//iconv_open.3.html
/usr/bin/install -c -m 644 ./iconv_open_into.3.html /usr/local/share/doc//iconv_open_into.3.html
/usr/bin/install -c -m 644 ./iconvctl.3.html /usr/local/share/doc//iconvctl.3.html
make[1]: Leaving directory `/usr/local/directadmin/custombuild/libiconv-1.15/man'
Done iconv.
MySQL 5.5 cannot be directly upgraded to 5.7
If you wish to upgrade MySQL to 5.7, do it in increments, upgrading 5.5 to the next version released, and going up until you reach 5.7.
*******************************************
*******************************************

Cannot find /usr/local/bin/php
Please recompile php with custombuild, eg:
cd /usr/local/directadmin/custombuild
./build all d

*******************************************
*******************************************



Then a VERY VERY VERY long pause

Not sure if this is an issue with the MYSQL install or PHP, but regardless it stops here so I can never get a DA password, etc..

Any ideas how to solve this one?
 

darkus

Verified User
Joined
Dec 15, 2005
Messages
114
Nevermind,

I solved this my editing /usr/local/directadmin/custombuild/options.conf and setting mysql to version 5.6, then running the setup script again and it all seemed to work now
 
Top