Autoconf/Imagick issue with PHP 7.3 on Centos 6

Bastille

Verified User
Joined
Mar 25, 2013
Messages
92
For some reason, Imagick seems to fail to install with PHP 7.3, and only PHP 7.3, on Centos 6. It works just fine with PHP 7.2, 7.1, 5.6, and 5.3.

Code:
Installing imagick-3.4.4 PHP extension for PHP 73...
Found /usr/local/directadmin/custombuild/imagick-3.4.4.tgz
Extracting /usr/local/directadmin/custombuild/imagick-3.4.4.tgz...
Configuring for:
PHP Api Version:         20180731
Zend Module Api No:      20180731
Zend Extension Api No:   320180731
configure.ac:3: error: Autoconf version 2.68 or higher is required
configure.ac:3: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
./build: line 14757: ./configure: No such file or directory
Trying to make imagick-3.4.4 PHP extension...
make: *** No targets specified and no makefile found.  Stop.
In options.conf, autoconf=yes is set so Autoconf 2.49 should be present already.

I've tried both ./build autoconf as well as manually installing Autoconf 2.69, to see if it makes a difference and it does not. The Centos 7 servers don't throw the same error so it's definitely tied to Centos 6 somehow. These servers are going to be switched over to Centos 7 or 8 later on in the year so it will eventually solve itself. For now though, I'd like to make sure that if a customer on these servers is using PHP 7.3 and Imagick that they don't encounter any issues in doing so.
 
Top