Backup skip files, keep everything else but as a second backup

chrismfz

Verified User
Joined
Jul 3, 2019
Messages
22
I use the system-backup to create everyday full backups of all users.

But from what I understand I cannot create multiple profiles. (One full to x destination, one structure/db only at y destination and so on)

I also need (for psychological reasons) a full backup without the home dir. Just the structure, mail accounts, zone information-domain information and of course databases.

In cPanel is use something like this in a cron or directly from console. Is the a DirectAdmin equivalent ?

Code:
my @cpusers = Cpanel::Config::Users::getcpusers();
foreach my $user (@cpusers) {

  my $cmd = "/scripts/pkgacct --skiphomedir  " . $user . " /home/tarballs/   2>&1";
I saw this http://forum.directadmin.com/showthread.php?t=58089 but i think it's globally. I need it separated. So I can run it from terminal or in a cron without affecting the full backups I already configured in UI.


I also saw this:
https://help.directadmin.com/item.php?id=198
But in the command line I didn't saw something like "skip homedir" just emails and databases:
Code:
&database%5Fdata%5Faware=yes&email%5Fdata%5Faware=yes
I think I want the exact opposite :cool: (skip home, and don't skip anything else like domains, mails, DBs...)
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
Hello,

There are no tools in DirectAdmin to recover anything from "system backups" from Admin level. You'd better use another type of a backup "Admin Backup/Transfer". It will give you more options and flexibility.
 

chrismfz

Verified User
Joined
Jul 3, 2019
Messages
22
I am sorry, didn't explained it good enough + I messed up.

I thought user backups don't have multiple profiles. I was wrong, they do.

So I got a full backup remotely and need a local "empty" backup. Structure only.

But I don't see them in "Restore" section and I thought I did something wrong.
admin_backups.PNG


restore_empty.PNG
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
If you see then in restore section using Enhanced skin, then it's a bug in Evolution skin. If you don't see them with any skin, then it might be an issue with permissions. Or you need to change a folder to a sub-folder.
 
Top