./build all but ERROR.Please help me

zhaorong65

Verified User
Joined
May 7, 2011
Messages
10
I would like to upgrade my version of directadmin to 5.3.6 in the PHP, may I ask how to do? My current version is 5.2.17.
I used to perform:. / build all
But the returns this error message: [root @ free custombuild] #. / build all
configure files.e 2.2
There is wrong default PHP in / usr / local / directadmin / custombuild / options.conf set.
 

kivivaj

New member
Joined
Aug 31, 2012
Messages
3
need help please, im give same error, im novicee

[root@server1 custombuild]# ./build used_configs
configure files.e 2.2

apparently the error refers to the line ( #Possible values - 1.3, 2.0, 2.2 or 2.4
apache_ver=2.2 ) but as I can not fix it. I need to configure php to install a game panel. urgent please'm tired of reading and not find solution.

[root@server1 custombuild]# php -v
PHP 5.2.17 (cli) (built: Apr 13 2012 01:59:11)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd.
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,793
Location
A Coruña, Spain
configure files.e 2.2

You did paste this, apparently the error is something in the file that is written in a wrong format.

Prolly is the line:

apache_ver=

Make sure it is like this:

apache_ver=2.2

From your error to me seems that there is a "e" near 2.2

Regards
 

kivivaj

New member
Joined
Aug 31, 2012
Messages
3
that file I have never touched this as DirectAdmin installed, I still see the error.

#PHP settings. default_php possible values - 4 or 5, php5_ver - 5.2, 5.3 or 5.4
default_php=5
php5_ver=5.2
php4_cli=no
php4_cgi=no
php5_cli=yes
php5_cgi=no
ioncube=yes
zend=yes
#Possible values - recommended or dist
php_ini_type=recommended

#Possible values - 5.0, 5.1, 5.5
mysql=5.0
mysql_inst=no
mysql_backup=yes
mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups

#Possible values - 1.3, 2.0, 2.2 or 2.4
apache_ver=2.2
secure_htaccess=no
harden-symlinks-patch=yes

#Web applications
phpmyadmin=yes
atmail=no
squirrelmail=yes
roundcube=yes
uebimiau=no

#Mail options
exim=no
eximconf=no
clamav=no
mailman=no
spamassassin=no
mail-header-patch=yes
dovecot=yes

#Statistics
awstats=no
webalizer=yes

#FTP options
proftpd=no
pureftpd=no

#Jailed shell (beta)
jail=no

#Autoconf/automake/libtool options
autoconf=yes
automake=yes
libtool=yes
curl=yes

#new version of zlib and libxml2 (experts only)
new_zlib=no

#CustomBuild options
custombuild=1.1
autover=no
bold=yes
clean=yes
clean_old_tarballs=no
clean_old_webapps=yes
downloadserver=files2.directadmin.com
cleanapache=no

#Cron settings
cron=no
email=email@domain.com
notifications=yes
da_autoupdate=no
updates=no
webapps_updates=yes

#CustomBuild 1.2 settings
php6_cli=no
php6_cgi=no
php_ini=no

#Cloudlinux settings
cloudlinux=no
cron_frequency=daily
 

kima

New member
Joined
Jul 20, 2013
Messages
3
A little bit out dated. But i had this problem right now.

The answer for me was that you have to edit the file in ssh like:
vi options.conf
(http://kb.iweb.com/entries/21186923-Editing-files-in-SSH-using-VI)

And not directly on you ftp program, that also did not work for me but on ssh with vi it did.

vi options.conf
hit "a"
edit the php to the right version you like.
hit escape
:wq (enter)

./build versions
./build update_versions
 
Top