./build update_versions returns perl errors

conconnl

Verified User
Joined
Feb 22, 2012
Messages
24
Hi All,

I'm not sure if this is the correct Forum Section.

I have a problem when i use ./build update_versions.
This is a new server and did all the changes i always do on every server.
Now on the end I used the update versions to be sure everything is updated.
This wouldn't work and returned the following error.

Code:
[root@server07 custombuild]# ./build update_versions

Jun 25 00:03:20.026 [7919] error: Socket version 1.95 required--this is only version 1.78 at /usr/lib/perl5/site_perl/5.8.8/IO/Socket/SSL.pm line 71.
Jun 25 00:03:20.027 [7919] error: Can't locate IO/Socket/IP.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8 /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/lib/perl5/site_perl/5.8.8/IO/Socket/SSL.pm line 85.
For as far as I can understand this has something to do with the SpamAssassin installation following help topic:
http://help.directadmin.com/item.php?id=36

Has anyone any idea how to solve this?

Regards,
Wilco
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
Have you read the link you posted?

There is the command there:

If you get errors building spamd relating to missing perl modules, try using cpan to install them:
Code:
cpan -i Archive::Tar Digest::SHA Mail::SPF IP::Country Net::Ident IO::Socket::INET6 Compress::Zlib Mail::DKIM LWP::UserAgent HTTP::Date Encode::Detect ExtUtils::MakeMaker NetAddr::IP Mail::SpamAssassin::Plugin::Razor2 Razor2::Client::Agent IO::Socket::SSL DBI
Regards
 

conconnl

Verified User
Joined
Feb 22, 2012
Messages
24
Hi,

I have used the link 6 times now on 6 different servers.
This is server number 7 and I did not have any problems installing.
Spamassassin works perfectly.

Only ./build update_versions does not work anymore, and gives the stated errors.
The errors states that somehow the versions are not correct, not that he is missing modules.
I tried to rerun the cpan modules installation but this does not change anything.

Regards
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
Im sorry, i did missread the error, thot was some module missing related.

Honestly i dont know how to solve this, perhaps someone else will reply with a correct one.

Regards
 

czotos

Verified User
Joined
Oct 19, 2007
Messages
216
I am having the exact same error message on a new server installation of DirectAdmin on CentOS 5 (32-bit).

Everything else appears to be working fine, except for SpamAssassin via CustomBuild...

Does anyone have any ideas?
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
Install the missing perl modules manually then.
 

conconnl

Verified User
Joined
Feb 22, 2012
Messages
24
The error is not that i'm missing modules.
The error is that these are the wrong version en yum update does not solve the problem.
If you know how to update/install or something like that please tell me.
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
Code:
perl -MCPAN -e 'CPAN::Shell->install(CPAN::Shell->r)'
 
Last edited:

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
Well the command should update perl modules, for sure not by yum.

For install by yum you should do:

yum install spamassassin -y && yum -y erase spamassassin

But after that i suggest you also to recompile spamassassin from custombuild

Regards
 

conconnl

Verified User
Joined
Feb 22, 2012
Messages
24
Code:
perl -MCPAN -e 'CPAN::Shell->install(CPAN::Shell->r)'
Hello scsi,

You command did not help.
It created just more errors.

Code:
[root@server07 custombuild]# ./build update_versions

Subroutine IO::Socket::INET6::pack_sockaddr_in6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 67.
 at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16.
Subroutine IO::Socket::INET6::unpack_sockaddr_in6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 67.
 at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16.
Subroutine IO::Socket::INET6::sockaddr_in6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 67.
 at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16.
Jun 25 19:39:53.860 [1157] error: Can't locate IO/Socket/IP.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8 /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/lib/perl5/site_perl/5.8.8/IO/Socket/SSL.pm line 85.
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
that should had updated cpan and his modules, if not, retry with:

Code:
cpan -i Archive::Tar Digest::SHA Mail::SPF IP::Country Net::Ident IO::Socket::INET6 Compress::Zlib Mail::DKIM LWP::UserAgent HTTP::Date Encode::Detect ExtUtils::MakeMaker NetAddr::IP Mail::SpamAssassin::Plugin::Razor2 Razor2::Client::Agent IO::Socket::SSL DBI
For re-install/update modules

Regards
 

conconnl

Verified User
Joined
Feb 22, 2012
Messages
24
That did not help.
It's all very strange.
It's a completely new server.

Is there a way to remove it completely?
So that i can restart the installation.
 

conconnl

Verified User
Joined
Feb 22, 2012
Messages
24
Andrea you are wonderful.
Somehow the yum install spamassassin -y && yum -y erase spamassassin installed the correct versions and solved the warnings.

Edit: The same moment i received a e-mail from the server provider.
I gonna ask them what they did and post it here.

edit2: the server provider told me he did.
# cpan
> fforce install IO::Socket::SSL

Edit3:
Now i tried to install spamassasin again through the topic and while i get errors again.
I asked the server provider to solve this
 
Last edited:

Trans-IX B.V.

Verified User
Joined
Mar 4, 2009
Messages
31
Location
The Netherlands
I just got the following error:

Code:
Jul  3 16:27:30.167 [29358] error: Socket version 1.95 required--this is only version 1.82 at /usr/local/share/perl5/IO/Socket/SSL.pm line 71.
Jul  3 16:27:30.167 [29358] error: Can't locate IO/Socket/IP.pm in @INC (@INC contains: /usr/share/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5) at /usr/local/share/perl5/IO/Socket/SSL.pm line 85.
You can fix it by installing the IO-Socket-SSL through YUM:

Code:
yum install perl-IO-Socket-SSL -y
Fixed.. :)
 

Babah

Verified User
Joined
Jun 30, 2012
Messages
6
I just got the following error:

Code:
Jul  3 16:27:30.167 [29358] error: Socket version 1.95 required--this is only version 1.82 at /usr/local/share/perl5/IO/Socket/SSL.pm line 71.
Jul  3 16:27:30.167 [29358] error: Can't locate IO/Socket/IP.pm in @INC (@INC contains: /usr/share/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5) at /usr/local/share/perl5/IO/Socket/SSL.pm line 85.
You can fix it by installing the IO-Socket-SSL through YUM:

Code:
yum install perl-IO-Socket-SSL -y
Fixed.. :)
I've got same error and try to fix it by using your code but the error still occure :(

any help ?
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,791
Location
A Coruña, Spain
On a customer server is happening the same, using yum install spamassassin (and than remove) fix, but spamassassasin ofc stop working till i reinstall from custombuild, after rebuild, error appear again :)


Just one server like this, all others are working.

Any idea?

Regards
 

conconnl

Verified User
Joined
Feb 22, 2012
Messages
24
As you know i had some of these problems.
My server provider has looked at it and he fixed all errors.

I only know what he told me:
# cpan
> fforce install IO::Socket::SSL

perl -MCPAN -e shell
cpan[1]> install IO::Socket::IP

After this a didn't see any problems any more
 

Babah

Verified User
Joined
Jun 30, 2012
Messages
6
in my case this error fixed by doing :

Code:
# perl -MCPAN -e 'CPAN::Shell->install(CPAN::Shell->r)'
just say No [no] to all prompt :)

good luck :D
 
Top