Solved Building Exim with -lpthread


Verified User
Jul 13, 2013
While still struggling with this problem in other thread I get some help from the Almalinux community
Jason Tucker

I don't think that's related to the OS migration specifically, but... do your build options contain -lpthread? If not, try adding it.

So there is something changed in the Makefile of Exim apparently , later I have found this in DA wiki
If you need to customize the Makefile, type:

cd /usr/local/directadmin/custombuild mkdir -p custom/exim/ wget -O custom/exim/Makefile

Edit the custom/exim/Makefile , and use #1, above, to compile it.

I have take an look at the Mafifile file but have totally no clue how to build this with -lpthread option
Can someone help me with this ?
Also an question for the @DirectAdmin Support : is there any changes made with the Makefile for exim 4.96 ?
Hi @jamgames2 thank you for your fast reply,
glibc-devel was installed on Centos 7 already but like you said maybe with the upgrade AL 8 dont update it while upgrading
I will test this with my next attempt with this server