Cannon create subdomain

algirdas

Verified User
Joined
Nov 3, 2018
Messages
7
Hello guys,
I'm having a hard time creating subdomain. I have two servers - multisite enabled.
Both servers are almost identical Debian 9 - exept for specifications(one has more RAM and HDD).
On one server subdomain creates instantly and everything works. On the second - timeouts while creating.
DNS record created, but folder, nginx config is not created.

Things tried so far:
Complete reinstallation,
set_permissions.sh all,
I also have this error log, but it's not helpful
/var/log/directadmin/error.log
2019:08:17-19:01:53: Can't connect to ssl!
2019:08:17-19:01:53: -> A failure in the SSL library occurred, usually a protocol error.
2019:08:17-19:01:53: -> error:00000001:lib(0):func(0):reason(1)
2019:08:17-19:02:03: Can't connect to ssl!
2019:08:17-19:02:03: ->syscall
2019:08:17-19:03:13: Timeout (timeout=60) from xx.xx.xx.xxx : last flagged: Named::readDB:: done reading data : /etc/bind/domainname.eu.db : getlock(./data/admin/cluster.conf, 'ConfigFile::readFile') : finished

Maybe somebody experienced this issue?
 

algirdas

Verified User
Joined
Nov 3, 2018
Messages
7
Ok it seems to be the problem with multisite.
I have two servers with enabled multisite.
Server A points to server B
Server B points to server A
Server A can create subdomains, but server B cannot.
If I disable multisite on server B I can create subdomains in it, but dns zones doesn't transfer to server A.
Maybe somebody have a solution for this problem?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,140
Location
GMT +7.00
Hello,

It would mean the server B can not connect to server A over 2222 port. Check your firewall then,
 

algirdas

Verified User
Joined
Nov 3, 2018
Messages
7
Hello,

It would mean the server B can not connect to server A over 2222 port. Check your firewall then,
Code:
algirdas@serverB:~$ curl https://serverA.com:2202
<!DOCTYPE html>
<html>
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8;"/>
        <meta name="viewport" content="width=device-width, initial-scale=1"/>
        
        <title>
            Login
        </title>
        <link rel="shortcut icon" href="/images/favicon.png" type="image/x-icon" />
        <meta name="robots" content="noindex,nofollow" />
        <script>
            var tokens = {
                LOST_PASSWORD: "no" === "yes",
                TIME: {
                    current: 1566123756 * 1000,
                    offset: 86400 * 1000,
                },
                AUTH_METHOD: "CMD_LOGIN",
                QUESTION: "|QUESTION_JSON|",
                LOGIN_LANGUAGES: "default=en;en=English;",
            };
        </script>
    <link href="/assets/css/login.css" rel="stylesheet"></head>
    <body>
        <div id="login"></div>
    <script type="text/javascript" src="/assets/login.js"></script></body>


algirdas@serverA:~$ curl https://serverB.com:2202
<!DOCTYPE html>
<html>
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8;"/>
        <meta name="viewport" content="width=device-width, initial-scale=1"/>
        
        <title>
            Login
        </title>
        <link rel="shortcut icon" href="/images/favicon.png" type="image/x-icon" />
        <meta name="robots" content="noindex,nofollow" />
        <script>
            var tokens = {
                LOST_PASSWORD: "no" === "yes",
                TIME: {
                    current: 1566123736 * 1000,
                    offset: 86400 * 1000,
                },
                AUTH_METHOD: "CMD_LOGIN",
                QUESTION: "|QUESTION_JSON|",
                LOGIN_LANGUAGES: "default=en;en=English;",
            };
        </script>
    <link href="/assets/css/login.css" rel="stylesheet"></head>
    <body>
        <div id="login"></div>
    <script type="text/javascript" src="/assets/login.js"></script></body>
Images:
ServerA
ServerB


Connection seems to be ok, unless ssh is used, but as I've read api is used for multisite
 

algirdas

Verified User
Joined
Nov 3, 2018
Messages
7
Hello,

It would mean the server B can not connect to server A over 2222 port. Check your firewall then,
Images:
ServerA
ServerB


Connection seems to be ok, unless ssh is used, but as I've read api is used for multisite.
Also I've tried with curl - connection is ok.
 

algirdas

Verified User
Joined
Nov 3, 2018
Messages
7
Thank you poralix.com for support! I recommend them, fast support and good problem solving!
 
Top