cannot install Mariadb 10.3 using Custombuild

wtptrs

Verified User
Joined
Jul 13, 2015
Messages
71
Issue: Mariadb 10.3.7 tar.gz install file not found on files.directadmin.com

OS: Debian 9 fresh install

/usr/local/directadmin/custombuild# ./build mariadb
Dumping database da_roundcube
Dumping database mysql
--2018-06-28 18:00:01-- http://files.directadmin.com/services/all/mariadb/10.3/10.3.7/mariadb-10.3.7-linux-x86_64.tar.gz
Resolving files.directadmin.com (files.directadmin.com)... 69.162.69.58, 216.144.254.90, 208.167.226.3
Connecting to files.directadmin.com (files.directadmin.com)|69.162.69.58|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2018-06-28 18:00:01 ERROR 404: Not Found.

Failed to download http://files.directadmin.com/services/all/mariadb/10.3/10.3.7/mariadb-10.3.7-linux-x86_64.tar.gz. Exiting...


Same issue for earlier version 10.3.6. 10.2.x installs fine.
 

ayeweb

Verified User
Joined
Nov 27, 2016
Messages
61
Is it ok to upgrade from Mariadb 10.2 to Mariadb 10.3?
Thanks
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,853
Location
GMT +7.00
Checked MySQL error log for clues? It might fail to start due to a deprecated options in my.cnf files, see /etc/my.cnf and /etc/my.cnf.d/*
 

R1977

New member
Joined
Mar 21, 2016
Messages
2
Same problem here with a fresh installation of Debian 9.5. MariaDB 10.2 installs without a problem, but 10.3 fails and won't start. I tried archives from servers files.da, files5.da and files6.da, all fail the installation.
I scanned the logs and all information seems to be from the 10.2 version, so 10.3 doesn't even seem to log it's errors.

Can someone help me with this issue?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,331
Location
LT, EU
Please check if "./build update" solves it :) If not, I'd recommend creating a ticket at tickets.directadmin.com and we will check it for you.
 

R1977

New member
Joined
Mar 21, 2016
Messages
2
Thank you for your quick reply. Unfortunately this didn't help, so I will create a ticket.
 

wattie

Verified User
Joined
May 31, 2008
Messages
992
Location
Bulgaria
I am joining the group of people with problems with 10.3, but not on Debian, but FreeBSD.

It compiles perfectly fine and then it just won't start. I don't know why. Error logs show nothing helpful (except that it was unable to start with no helpful error message).
 
Top