Cannot install PHP7.4, build will not start

Erik66

Verified User
Joined
Sep 21, 2016
Messages
20
Location
Zwolle, The Netherlnads
Hello, I'm trying to set my php1 to PHP 7.4 using custombuild. Current PHP version of php1 is 7.1.33. I get the following output:

Executing /usr/local/directadmin/plugins/custombuild/admin/build php_expert 7.4 php-fpm...
Found /usr/local/directadmin/custombuild/php-7.4.4.tar.gz
Extracting ...
Done.
Configuring php-7.4.4...
Patching php-fpm to not fail on startup if User quota maxed out on socket chown
patching file sapi/fpm/fpm/fpm_unix.c
Hunk #1 succeeded at 234 (offset -1 lines).
Done!

Build does not start, PHP version is not updated, php1 stays on 7.1.33.

I tried CLI ./build php n and get the same result

Does anyone have an idea how to solve this?

System: CentOS 7.7
DirectAdmin: 1.60.4
Custombuild: 2.0
 

anay

Verified User
Joined
Dec 7, 2005
Messages
78
Have you tried PHP 7.3 by any chance ,see if that works...

Code:
cd /usr/local/directadmin/custombuild
./build update
./build set php1_release 7.3
./build set php1_mode php-fpm
./build php n
./build rewrite_confs
 

Erik66

Verified User
Joined
Sep 21, 2016
Messages
20
Location
Zwolle, The Netherlnads
Thank you Richard, here they are:

Code:
#PHP Settings
php1_release=7.4
php1_mode=php-fpm
php2_release=5.6
php2_mode=php-fpm
php3_release=7.2
php3_mode=php-fpm
php4_release=7.3
php4_mode=php-fpm
php_ini=yes
php_timezone=Europe/Amsterdam
php_ini_type=production
x_mail_header=yes

#MySQL Settings
mysql=5.7
mysql_inst=mariadb
mysql_backup=yes
mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups
mysql_force_compile=no

#WEB Server Settings
webserver=apache
modsecurity=no
modsecurity_ruleset=no
apache_ver=2.4
apache_mpm=auto
mod_ruid2=no
harden_symlinks_patch=yes
use_hostname_for_alias=no
redirect_host=xxx.xxxxxxxx.xxx
redirect_host_https=yes

#WEB Applications Settings
phpmyadmin=yes
phpmyadmin_ver=4
squirrelmail=no
roundcube=no
webapps_inbox_prefix=no

#ClamAV-related Settings
clamav=yes
clamav_exim=yes
proftpd_uploadscan=no
pureftpd_uploadscan=no
suhosin_php_uploadscan=no

#Mail Settings
exim=yes
eximconf=yes
eximconf_release=4.5
blockcracking=no
easy_spam_fighter=no
spamd=no
dovecot=no
dovecot_conf=no
pigeonhole=no

#FTP Settings
ftpd=proftpd

#Statistics Settings
awstats=no
webalizer=no

#CustomBuild Settings
custombuild=2.0
autover=no
bold=yes
clean=yes
cleanapache=yes
clean_old_tarballs=yes
clean_old_webapps=yes
downloadserver=files.directadmin.com

#Cronjob Settings
cron=yes
cron_frequency=daily
email=xxx@xxxxxxx.xxx
notifications=yes
da_autoupdate=yes
updates=no
webapps_updates=no


#CloudLinux Settings
cloudlinux=no
cagefs=no

#Advanced Settings
autoconf=yes
automake=yes
libtool=yes
curl=yes
new_pcre=yes
sa_update=daily
modsecurity_uploadscan=no
litespeed_serialno=trial
userdir_access=no
mariadb=10.4
mysql_backup_gzip=no
cloudlinux_beta=no
http_methods=GET:HEAD:POST
secure_php=no
maildir_compress=no
mail_compress=no
custombuild_plugin=yes
phpmyadmin_public=yes
ssl_configuration=intermediate
unit=no
Servername and email obfuscated ofcourse

php1 is now set to 7.4 in options.conf but in reality the server is still running 7.1 for php1.

Thnx Erik
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,254
Location
Maastricht
php1 is now set to 7.4 in options.conf but in reality the server is still running 7.1 for php1.
Thank you, I only needed the php version part of your options.conf.

First check which version build script you are running as ericosman suggested.
This should be Version: 2.0.0 (rev: 2462). If it is, then it's good.

To exclude script problems by using the expert build feature, just try again in the normal way.
Code:
cd /usr/local/directadmin/custombuild
./build update
./build php
this might build all php versions.
You might have to do a ./build rewrite_confs afterwards and restart apache if not done automatically.

but in reality the server is still running 7.1 for php1.
Which way do you check this? By doing a php -v command? Or how?
If you do it by php -v command, try in some user level to change with the php switch menu if php 7.4 is there. If yes, activate and check on that user account with a phpinfo file or something like that.

Might be some bug or something, maybe this way we can retrieve and report it.
 

Erik66

Verified User
Joined
Sep 21, 2016
Messages
20
Location
Zwolle, The Netherlnads
To exclude script problems by using the expert build feature, just try again in the normal way.
Code:
cd /usr/local/directadmin/custombuild
./build update
./build php
this might build all php versions.
You might have to do a ./build rewrite_confs afterwards and restart apache if not done automatically.
I tried this and the output is slightly different:

Code:
./build php
Found /usr/local/directadmin/custombuild/php-7.4.4.tar.gz
Extracting ...
Done.
Configuring php-7.4.4...
Patching php-fpm to not fail on startup if User quota maxed out on socket chown
patching file sapi/fpm/fpm/fpm_unix.c
Hunk #1 succeeded at 234 (offset -1 lines).
Done Configuration.
Can't open Makefile: No such file or directory.
Trying to make php...
make: *** No targets specified and no makefile found.  Stop.
Does this point more towards a possible clue as to solve this?
 

Erik66

Verified User
Joined
Sep 21, 2016
Messages
20
Location
Zwolle, The Netherlnads
Which way do you check this? By doing a php -v command? Or how?
If you do it by php -v command, try in some user level to change with the php switch menu if php 7.4 is there. If yes, activate and check on that user account with a phpinfo file or something like that.

Might be some bug or something, maybe this way we can retrieve and report it.
Correct, php -v outputs this:

Code:
# php -v
PHP 7.1.33 (cli) (built: Apr  5 2020 16:18:54) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.1.33, Copyright (c) 1999-2018, by Zend Technologies
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,305
Location
LT, EU
I think you have a custom config for 7.4, which is likely empty at all :) Check custom/ directory for it.
 

Erik66

Verified User
Joined
Sep 21, 2016
Messages
20
Location
Zwolle, The Netherlnads
I think you have a custom config for 7.4, which is likely empty at all :) Check custom/ directory for it.
Thank you for the suggestion smtalk. I checked /usr/local/directadmin/custombuild/custom/ but there is no custom config file there. Or should I look in another place?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,305
Location
LT, EU
Thank you for the suggestion smtalk. I checked /usr/local/directadmin/custombuild/custom/ but there is no custom config file there. Or should I look in another place?
That’s the place to check. Would you like to PM me with access details? It must be something very obvious :)
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,305
Location
LT, EU
Thank you for the suggestion smtalk. I checked /usr/local/directadmin/custombuild/custom/ but there is no custom config file there. Or should I look in another place?
It seems it wasn't true:
Code:
[root@s03 custombuild]# ls -la /usr/local/directadmin/custombuild/custom/fpm/configure.php74
-rwx------ 1 root root 0 Apr  7 00:48 /usr/local/directadmin/custombuild/custom/fpm/configure.php74
[root@s03 custombuild]# cat /usr/local/directadmin/custombuild/custom/fpm/configure.php74
[root@s03 custombuild]#
Remove that empty file and it should start to work then :)
 

Erik66

Verified User
Joined
Sep 21, 2016
Messages
20
Location
Zwolle, The Netherlnads
I removed the empty file /usr/local/directadmin/custombuild/custom/fpm/configure.php74 and started a new build. Which is now in progress. So that's working !
 
Top