Cannot rebuild exim

asmar

Verified User
Joined
Aug 29, 2005
Messages
96
Hi all,

I'm trying to follow this guide http://help.directadmin.com/item.php?id=576 with no luck.
When I run ./build exim_conf I'm getting the following error:

Your version of Exim does not support SPF, which is needed for Easy Spam Fighter. Please updat
e exim using the CustomBuild script: ./build exim.

Then I run just ./build exim and getting the following results/error:


root@is-26285:/usr/local/directadmin/custombuild# ./build exim
Found /usr/local/directadmin/custombuild/exim-4.87.tar.gz
Extracting ...
Done.
converted 'http://files4.directadmin.com/services/custombuild/Makefile' (ANSI_X3.4-1968) -> 'h
ttp://files4.directadmin.com/services/custombuild/Makefile' (UTF-8)
--2016-07-18 14:04:12-- http://files4.directadmin.com/services/custombuild/Makefile
Resolving files4.directadmin.com (files4.directadmin.com)... 193.105.61.16
Connecting to files4.directadmin.com (files4.directadmin.com)|193.105.61.16|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-07-18 14:04:12 ERROR 404: Not Found.

Trying to make exim...
/bin/sh scripts/source_checks

>>> Creating links to source files...
>>> Creating lookups/Makefile for building dynamic modules
>>> New Makefile & lookups/Makefile installed
>>> Use "make makefile" if you need to force rebuilding of the makefile

make[1]: Entering directory '/usr/local/directadmin/custombuild/exim-4.87/build-Linux-x86_64'
/bin/sh ../scripts/Configure-os.c
gcc buildconfig.c
/bin/sh ../scripts/Configure-config.h "make"
make[2]: Entering directory '/usr/local/directadmin/custombuild/exim-4.87/build-Linux-x86_64'
make[2]: 'buildconfig' is up to date.
make[2]: Leaving directory '/usr/local/directadmin/custombuild/exim-4.87/build-Linux-x86_64'
Building configuration file config.h

*** BIN_DIRECTORY has not been defined in any of the Makefiles in the
"Local" directory. Please review your build-time configuration.

Makefile:175: recipe for target 'config.h' failed
make[1]: *** [config.h] Error 1
make[1]: Leaving directory '/usr/local/directadmin/custombuild/exim-4.87/build-Linux-x86_64'
Makefile:29: recipe for target 'all' failed
make: *** [all] Error 2
-e
Any help is much appreciated.
 

BBM

Verified User
Joined
Jun 8, 2013
Messages
340
Location
Dutch Mountains
Change the download server in directadmin conf from "files4." to another.
CB doesn't seem to automaticly switch to a different server that 'is' online but still tries to apply the update, which then fails.

IMO, the CB updatescript should stop (or check first) when/if a DA-update mirrorserver is not found, or fallback to the main-update server "files1".
 
Top