can't install Wordpress on my Server

bigboy

Verified User
Joined
Nov 25, 2005
Messages
231
Location
USA
CentOS 5.10 64-bit

Apache 2.2.22 Running
DirectAdmin 1.48.0 Running
Exim 4.77 Running
MySQL 5.1.62 Running
Named 9.3.4 Running
ProFTPd 1.3.4b Running
sshd Running
dovecot 2.1.9 Running
Php 5.2.17 Installed


can't install Wordpress on my Server error



?php /** * Defines constants and global variables that can be overridden, generally in wp-config.php. * * @package WordPress */ /** * Defines initial WordPress constants * * @see wp_debug_mode() * * @since 3.0.0 */ function wp_initial_constants() { global $blog_id; // set memory limits if ( !defined('WP_MEMORY_LIMIT') ) { if( is_multisite() ) { define('WP_MEMORY_LIMIT', '64M'); } else { define('WP_MEMORY_LIMIT', '40M'); } } if ( ! defined( 'WP_MAX_MEMORY_LIMIT' ) ) { define( 'WP_MAX_MEMORY_LIMIT', '256M' ); } /** * The $blog_id global, which you can change in the config allows you to create a simple * multiple blog installation using just one WordPress and changing $blog_id around. * * @global int $blog_id * @since 2.0.0 */ if ( ! isset($blog_id) ) $blog_id = 1; // set memory limits. if ( function_exists( 'memory_get_usage' ) ) { $current_limit = @ini_get( 'memory_limit' ); if ( -1 != $current_limit && ( -1 == WP_MEMORY_LIMIT || ( intval( $current_limit ) < abs( intval( WP_MEMORY_LIMIT ) ) ) ) ) @ini_set( 'memory_limit', WP_MEMORY_LIMIT ); } if ( !defined('WP_CONTENT_DIR') ) define( 'WP_CONTENT_DIR', ABSPATH . 'wp-content' ); // no trailing slash, full paths only - WP_CONTENT_URL is defined further down // Add define('WP_DEBUG', true); to wp-config.php to enable display of notices during development. if ( !defined('WP_DEBUG') ) define( 'WP_DEBUG', false ); // Add define('WP_DEBUG_DISPLAY', null); to wp-config.php use the globally configured setting for // display_errors and not force errors to be displayed. Use false to force display_errors off. if ( !defined('WP_DEBUG_DISPLAY') ) define( 'WP_DEBUG_DISPLAY', true ); // Add define('WP_DEBUG_LOG', true); to enable error logging to wp-content/debug.log. if ( !defined('WP_DEBUG_LOG') ) define('WP_DEBUG_LOG', false); if ( !defined('WP_CACHE') ) define('WP_CACHE', false); /** * Private */ if ( !defined('MEDIA_TRASH') ) define('MEDIA_TRASH', false); if ( !defined('SHORTINIT') ) define('SHORTINIT', false); // Constants for expressing human-readable intervals // in their respective number of seconds. define( 'MINUTE_IN_SECONDS', 60 ); define( 'HOUR_IN_SECONDS', 60 * MINUTE_IN_SECONDS ); define( 'DAY_IN_SECONDS', 24 * HOUR_IN_SECONDS ); define( 'WEEK_IN_SECONDS', 7 * DAY_IN_SECONDS ); define( 'YEAR_IN_SECONDS', 365 * DAY_IN_SECONDS ); } /** * Defines plugin directory WordPress constants * * Defines must-use plugin directory constants, which may be overridden in the sunrise.php drop-in * * @since 3.0.0 */
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,161
Location
GMT +7.00
Hello,

Make sure and check in directadmin that PHP is enabled for an user and a domain.
 

Tommyhara

Verified User
Joined
Jul 25, 2014
Messages
162
?php /** * Defines constants and global variables that can be overridden, generally in wp-config.php
From this line, you should check wp-config.php and see something wrong there.

and check WP_MEMORY_LIMIT if your site is running with an ecommerce plugin which can need to change this point.
 

24x7server

Verified User
Joined
Apr 17, 2013
Messages
81
I think, its a memory_limit issue. Increase it and then to install WordPress. :)
 
Top