Centos6 compatibility

ViAdCk

Verified User
Joined
Feb 14, 2005
Messages
266
Hello,

Some of our clients using Centos 6.10 are interested in testing out rspamd but it appears it's only compatible with Centos7.

Any idea if rspamd will be available for Centos6 users at some point?

Regards
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,818
Location
GMT +7.00
Hello,

Why do you think it's not compatible with CentOS 6?

Code:
[root@server custombuild]# cat /etc/redhat-release
[B]CentOS release 6.10 (Final)[/B]

[root@server custombuild]# ps aux | grep spam
root     21869  0.0 18.4 250320 92512 ?        Ss   01:39   0:00 rspamd: main process
_rspamd  21871  0.0 18.6 250320 93068 ?        S    01:39   0:00 rspamd: rspamd_proxy process (localhost:11332)
_rspamd  21872  0.9 19.3 251100 96604 ?        S    01:39   0:00 rspamd: controller process (localhost:11334)
_rspamd  21873  0.0 18.9 250320 94612 ?        S    01:39   0:00 rspamd: normal process (localhost:11333)
_rspamd  21874  6.3 19.3 250320 96564 ?        S    01:39   0:00 rspamd: hs_helper process
root     22589  0.0  0.4 103448  2164 pts/0    S+   01:39   0:00 grep spam


[root@server custombuild]# ./build options | grep -i spam
Easy Spam Fighter: no
[B]Rspamd: 1.8.1[/B]
 

ViAdCk

Verified User
Joined
Feb 14, 2005
Messages
266
I have enabled rspamd on a centos 6.10 server but it doesn't appear to be working.

I did the following to install rspamd:

Code:
cd /usr/local/directadmin/custombuild
./build update
./build set spamd rspamd
./build rspamd
./build exim_conf
It appears to be running correctly:

Code:
root      8155  0.0  0.5 197192 43680 ?        Ss   12:25   0:00 rspamd: main process                                            
_rspamd   8157  0.0  0.5 197192 43648 ?        S    12:25   0:00 rspamd: rspamd_proxy process (localhost:11332)                  
_rspamd   8158  0.0  0.5 197972 44840 ?        S    12:25   0:00 rspamd: controller process (localhost:11334)                    
_rspamd   8160  0.0  0.5 197192 44568 ?        S    12:25   0:00 rspamd: normal process (localhost:11333)                        
_rspamd   8161  0.0  0.5 197192 47824 ?        S    12:25   0:00 rspamd: normal process (localhost:11333)                        
_rspamd   8164  0.0  0.4 197192 41472 ?        S    12:25   0:00 rspamd: hs_helper process                                       
root     12100  0.0  0.0   6712   752 pts/0    S+   12:31   0:00 grep spam
But the headers don't show rspamd scanning the email:

Forward-Confirmed-ReverseDNS: Reverse and forward lookup success on 209.85.208.49, -10 Spam score
SPFCheck: Server passes SPF test, -30 Spam score
X-DKIM: signer='gmail.com' status='pass' reason=''
DKIMCheck: Server passes DKIM test, -20 Spam score
SpamTally: Final spam score: -64
X-Antivirus-Scanner: Clean mail though you should still use an Antivirus
Any idea what could be going on?
 

ViAdCk

Verified User
Joined
Feb 14, 2005
Messages
266
When I try to edit the spamassasin settings inside a user account I get the following error:

Error Saving settings

Detalles

Error reading /etc/rspamd/directadmin-users.conf: Unable to get Lock on file:
open error for /etc/rspamd/directadmin-users.conf.lock: Success
/etc/rspamd: 'root:root' drwxr-xr-x, running as _rspamd:_rspamd
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,818
Location
GMT +7.00
Requires:

- SpamBlocker (exim.conf) 4.5+
- EasySpamFighter 1.17+




Installation:


Let CustomBuild do it for you.
Code:
cd /usr/local/directadmin/custombuild
./build update
./build set eximconf yes
./build set eximconf_release 4.5
./build set blockcracking yes
./build set easy_spam_fighter yes
./build set spamd rspamd
./build set exim yes
./build exim
./build rspamd
./build exim_conf
 

vlijmenlive

Verified User
Joined
Nov 13, 2013
Messages
61
Location
Belgium
I'm having the same "issue" that the rspamd headers don't show up (Centos6).
In custombuild I can't set release 4.6, but changing the options.conf manually works.

I can see in /etc/exim.conf that it's being used and rspamd is running, but still no headers.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,818
Location
GMT +7.00
I've got this:

Code:
Forward-Confirmed-ReverseDNS: Reverse and forward lookup success on 94.100.177.99, -10 Spam score
SPFCheck: Server passes SPF test, -30 Spam score
X-DKIM: signer='mail.ru' status='pass' reason=''
DKIMCheck: Server passes DKIM test, -20 Spam score
X-Spam-Bar: +
SpamTally: Final spam score: -49
even this:

Code:
Forward-Confirmed-ReverseDNS: Reverse and forward lookup success on 198.2.182.13, -10 Spam score
SPFCheck: Server passes SPF test, -30 Spam score
X-DKIM: signer='mailchimpapp.net' status='pass' reason=''
DKIMCheck: Server passes DKIM test, -20 Spam score
X-DKIM: signer='info=3Dpushtolearn.com@mailchimpapp.net' status='pass' reason=''
X-Spam-Score: 6.1 (++++++)
X-Spam-Report: Action: add header
 Symbol: HAS_REPLYTO(0.00)
 Symbol: R_SPF_ALLOW(-0.20)
 Symbol: ZERO_FONT(0.10)
 Symbol: TO_DN_NONE(0.00)
 Symbol: DKIM_TRACE(0.00)
 Symbol: FROM_EXCESS_QP(1.20)
 Symbol: RCVD_NO_TLS_LAST(0.10)
 Symbol: MIME_TRACE(0.00)
 Symbol: ASN(0.00)
 Symbol: FROM_NEQ_ENVFROM(0.00)
 Symbol: ARC_NA(0.00)
 Symbol: R_DKIM_ALLOW(-0.20)
 Symbol: REPLYTO_EQ_FROM(0.00)
 Symbol: FROM_HAS_DN(0.00)
 Symbol: TO_MATCH_ENVRCPT_ALL(0.00)
 Symbol: INFO_TO_INFO_LU(2.00)
 Symbol: MIME_GOOD(-0.10)
 Symbol: PREVIOUSLY_DELIVERED(0.00)
 Symbol: DMARC_NA(0.00)
 Symbol: HAS_LIST_UNSUB(-0.01)
 Symbol: RCPT_COUNT_ONE(0.00)
 Symbol: HTML_SHORT_LINK_IMG_1(2.00)
 Symbol: MANY_INVISIBLE_PARTS(0.05)
 Symbol: REPLYTO_EXCESS_QP(1.20)
 Symbol: FORGED_SENDER_VERP_SRS(0.00)
 Symbol: RCVD_COUNT_TWO(0.00)
 Message: (SPF): spf allow
 Message-ID: 130aa02c43f217af396b5ef91.9a92e166d1.20190405125901.33e1642559.bce8ca0d@mail13.suw15.mcsv.net
X-Old-Subject:=?utf-8?Q?=D0=94=D0=BE=D1=80=D0=B0=D0=B1=D0=BE=D1=82=D0=BA=D0=B0=20=D0=93=D1=80=D0=B0=D0=BC=D0=BC=D0=B0=D1=82=D0=B8=D0=BA=D0=B8=20=2D=20=D0=BF=D1=80=D0=B0=D0=B2=D0=B8=D0=BB=D0=B0=20=D0=B8=20=D1=81=D0=BF=D1=80=D0=B0=D0=B2=D0=BE=D1=87=D0=BD=D0=B0=D1=8F=20=D0=B8=D0=BD=D1=84=D0=BE=D1=80=D0=BC=D0=B0=D1=86=D0=B8=D1=8F?=
Subject: *****SPAM***** =?utf-8?Q?=D0=94=D0=BE=D1=80=D0=B0=D0=B1=D0=BE=D1=82=D0=BA=D0=B0=20=D0=93=D1=80=D0=B0=D0=BC=D0=BC=D0=B0=D1=82=D0=B8=D0=BA=D0=B8=20=2D=20=D0=BF=D1=80=D0=B0=D0=B2=D0=B8=D0=BB=D0=B0=20=D0=B8=20=D1=81=D0=BF=D1=80=D0=B0=D0=B2=D0=BE=D1=87=D0=BD=D0=B0=D1=8F=20=D0=B8=D0=BD=D1=84=D0=BE=D1=80=D0=BC=D0=B0=D1=86=D0=B8=D1=8F?=
X-Spam-Status: Yes, score=6.1, +20 total spam score
X-Spam-Bar: ++++++
SpamTally: Final spam score: 1

Check the logs under /var/log/rspamd/rspamd.log for details to see how it runs.

One possible issue I've found though, it is a blacklist which you can manage in directadmin interface on the old-way named SpamAssassin page, it does not block emails from black-listed email addresses. So if I have *@domain.com in a blocklist, emails still pass through....
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,905
Sorry for the confusion. There is no SB 4.6. I had an idea at one point, started it.. but 4.5.12 is already much newer.
I'll remove it from files.da to avoid further confusion :)

John
 
Top