CloudLinux+Apache fails due to exclude=liblsapi* on CentOS

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

It was found the /etc/yum.conf have now exclude=liblsapi* which breaks installation of Apache on CloudLinux 8 server.

Here are the final lines of ./build apache:

Code:
Install the project...
-- Install configuration: ""
-- Installing: /usr/lib/apache/mod_hostinglimits.so
-- Set runtime path of "/usr/lib/apache/mod_hostinglimits.so" to ""
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 2:48:55 ago on Wed Feb 19 20:20:03 2020.
Package yum-utils-4.0.12-1.el8.noarch is already installed.
No match for argument: python-lxml
Error: Unable to find a match: python-lxml
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 2:49:00 ago on Wed Feb 19 20:20:03 2020.
No match for argument:
Error: Unable to find a match
/usr/share/lve/da_lsapi /usr/local/directadmin/custombuild/mod_lsapi-1.1-48
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 2:49:05 ago on Wed Feb 19 20:20:03 2020.
No package available.
Exiting due to strict setting.
Error: No package available.
/usr/local/directadmin/custombuild/mod_lsapi-1.1-48
/usr/share/lve/da_lsapi /usr/local/directadmin/custombuild/mod_lsapi-1.1-48
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 2:49:09 ago on Wed Feb 19 20:20:03 2020.
No package available.
Exiting due to strict setting.
Error: No package available.
/usr/local/directadmin/custombuild/mod_lsapi-1.1-48
*** da_cb_install error: cannot download liblsapi 1.1-48 version ***
CMake Error: The source directory "/usr/local/directadmin/custombuild/mod_lsapi-1.1-48" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
make: Nothing to be done for 'install'.
Restarting apache.
Job for httpd.service failed because the control process exited with error code.
See "systemctl status httpd.service" and "journalctl -xe" for details.
[root@host12 custombuild]#

here are some details:

A script 'da_cb_install' runs the following code when installing mod_lsapi:

Code:
yumdownloader 'liblsapi-devel-1.1-48*' --disableexcludes=all --downloaddir=/usr/share/lve/da_lsapi/ ''
IMPORTANT is the latest argument, which is empty. In the script 'da_cb_install' it is the corresponding line:

Code:
yumdownloader liblsapi-"$VER"* --disableexcludes=all --downloaddir=/usr/share/lve/da_lsapi/ "$REPOSIT"
Whenever the $REPOSIT is empty the issue arises! See results of manual testing:

1. empty 4th argument with exclude=liblsapi* in /etc/yum.conf :

Code:
# yumdownloader 'liblsapi-devel-1.1-48*' --disableexcludes=all --downloaddir=/usr/share/lve/da_lsapi/ ''
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 1:06:05 ago on Wed 19 Feb 2020 11:54:40 PM AEDT.
No package available.
Exiting due to strict setting.
Error: No package available.
2. missing 4th argument with exclude=liblsapi* in /etc/yum.conf :

Code:
# yumdownloader 'liblsapi-devel-1.1-48*' --disableexcludes=all --downloaddir=/usr/share/lve/da_lsapi/
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 1:38:41 ago on Thu 20 Feb 2020 05:28:12 AM AEDT.
liblsapi-devel-1.1-48.el8.cloudlinux.x86_64.rpm                                                   44 kB/s |  48 kB     00:01
3. removed exclude=liblsapi* from /etc/yum.conf. Results are the same as in the 2nd example.

Thus to fix the issue we should

1. either remove exclude=liblsapi* from /etc/yum.conf
2. or modify 'da_cb_install' script
3. or set channel to beta:

Code:
./build set cloudlinux_beta yes
./build apache
When setting to beta, we get: REPOSIT="--enablerepo=cloudlinux-updates-testing"

So, at the install time and later then we need to use either beta channel of CloudLinux 8 and/or remove exclude=liblsapi* from /etc/yum.conf

Kindly advice.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,936
Location
LT, EU
It always had it, since the beginning of mod_lsapi support, to prevent library/mod_lsapi version mismatch. I'd suggest reporting it to CloudLinux if you're experiencing problems with it.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
A solution with removing liblsapi* from exclude=liblsapi* has been offered by them, i.e. support team from CloudLinux.

All the information in the post was sent to CloudLinux as well, and still they suggested to update /etc/yum.conf
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,936
Location
LT, EU
A solution with removing liblsapi* from exclude=liblsapi* has been offered by them, i.e. support team from CloudLinux.

All the information in the post was sent to CloudLinux as well, and still they suggested to update /etc/yum.conf
Yes, it's not the first report like this, but usually that's not from the team involved in integration/development of mod_lsapi :) As that just creates more issues.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
OK, I see. Meanwhile my suggestion was to modify 'da_cb_install' script, i.e. removing empty argument from the line with
yumdownloader.
 
Top