cloudlinux php selector + litespeed

mohamadsajedi

New member
Joined
Sep 10, 2021
Messages
3
hey there . after installing directadmin + cloudlinux + litespeed , now users cant change php version from php selector in DA panel.
all of the users are in cageFS. when they change php version from cloudlinux php selector nothing happend on http conf file ( normally it must change some line in users virtualhost conf, but it does not!)
i can change php version of users from /usr/local/directadmin/data/users/X/httpd.conf and when i restart the lsws service , i can see that php version has been changed .
what's problem? i read all of the posts and threads in DA forum .
Please help
thanks best regards
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
10,147
Location
LT, EU
CloudLinux PHP selector shouldn't add any lines to httpd.conf, it replaces php binary in CageFS. It must be a minor problem there. Maybe your customer has some PHP version selected in DA PHP selector, which overrides CL PHP Selector change?
 

mohamadsajedi

New member
Joined
Sep 10, 2021
Messages
3
normally when users change php version in CL php selector, this action must cause changing php version of their hosting account . but this is not happening right now! so where do you think the problem comes from?
also there is no external app on my litespeed server configurations console and no lsphp directory on server!!
i think that this main problem.
i've installed litespeed on DA like its tutorial...
 

Attachments

  • 1631276639482.png
    1631276639482.png
    326 bytes · Views: 3

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
10,147
Location
LT, EU
Go to "domain setup", click on the domain and check if it has default (main) PHP version selected.

External applications are detected automatically/dynamically in LiteSpeed.
 

mohamadsajedi

New member
Joined
Sep 10, 2021
Messages
3
Thank You @smtalk for your answer it worked !
so what is my mistake... i installed CL on server and that must control php and php versions.
how can i fix that?
best regards
 
Top