/CMD_SYSTEM_INFO timeout

roman_m

Verified User
Joined
May 5, 2005
Messages
130
Location
Ukraine, Kiev
When querying "System Information" th DirectAdmin hangs without any output for long time and I've got
"Your connection has timed out". This happened today when I install additional 8 Gb of RAM to server (16 Gb total).
That's what I see in DA error.log

2014:08:04-21:22:11: Timeout from from 95.132.***.*** : last flagged: getlock(/var/run/dmesg.boot) : finished
2014:08:04-21:23:20: Timeout from from 95.132.***.*** : last flagged: getlock(/var/run/dmesg.boot) : finished

This happens on FreeBSD 9.3 64bit

Dont' know what it mean, all other features seems to be fine, except this one.
DirectAdmin support, please contact me pm for any suggestions.

Thank you.
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,961
Hello,

Although I wasn't able to duplicate the error on our FreeBSD 9, 64-bit box, I've added extra debug code to the pre-release binaries, so we can try and track down where it's hanging.
http://help.directadmin.com/item.php?id=408

It's debug level 3000, so be sure to run at that level:
http://help.directadmin.com/item.php?id=293

The debug output points will all start with:
Code:
ServerInfo::fillTokens:
so when in debug mode, trigger the page, and see what code is output, before the hang happens (before it stops and generates the timeout).
Let me know what it shows, and we can go from there.

John
 

roman_m

Verified User
Joined
May 5, 2005
Messages
130
Location
Ukraine, Kiev
Thank you, John. I will try to run RC binaries with debug after client area is back to work. Some issues now, cant' login, got timeout from your webserver.
 

roman_m

Verified User
Joined
May 5, 2005
Messages
130
Location
Ukraine, Kiev
Solved.

Thank you very much for debug code! I solved a problem with help of it. That's my fake exim binary (/usr/sbin/exim), that imitates exim mail system. It reads STDIN and parameters, analyze the content of message, do some checks and then drops the message or send it to real exim binary.

When run with -bV with directadmin binary, fake binary waits for STDIN. Forever.

Just corrected it (add support for -bV) and everything all right now.

Thank you!

PS: Debug code really helped, without it I don't know about DA binary interacts with system service binaries to query versions.
 
Top