CSF bug?

jet1972

Verified User
Joined
Jul 8, 2011
Messages
250
I have suddenly got this:

You should consider disabling commonly abused php functions, e.g.:
disable_functions = show_source, system, shell_exec, passthru, exec, popen, proc_open
Some client web scripts may break with some of these functions disabled, so you may have to remove them from this list:
Affected PHP versions:
/usr/local/php74/lib/php.ini (/usr/local/bin/php)

I have disable_functions defined in the php config file and it is working but still I get this error.

This started about a month ago.

CSF is not barking for other versions of PHP 7.3 and 8.0

 

jamgames2

Verified User
Joined
Aug 16, 2019
Messages
944
php-fpm
currently csf look by cli ( /usr/bin/php, /use/local/bin/php ) , other php-mode I don't know any infomartion.

DA force remove "disable_functions" from php.ini when use by cli ( look at custombuild 2.0 change log).
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
9,981
Location
Maastricht
It's the same like Dovecot notices before, because CSF didn't look in the /etc/dovecot/conf.d directory, only in /etc/dovecot so missing some settings.
At the moment, CSF is indeed checking only those 2 directory's and not /usr/local/phpXX/lib for php.ini file which also causes the entry's not to be seen.
 
Top