CSF Messenger with reCAPTCHA doesn't work with DirectAdmin. Any fix ideas?

urgido

Verified User
Joined
Oct 28, 2008
Messages
401
That was exactly my thought too. I'm on CentOS 8 and Apache 2.4.46. I edited CSF config (/etc/csf/csf.conf) as follows:

Code:
MESSENGER = "1"
MESSENGER_HTTPS_IN = "443,2222"
MESSENGERV3 = "1"
MESSENGERV3WEBSERVER = "apache"
MESSENGERV3PHPHANDLER = ""

(I wasn't sure what I was supposed to put in the last one. I did try entering the path to '/etc/httpd/conf/extra/httpd-php-handlers.conf' but that didn't work, so I left it empty, which means 'the MESSENGER service will try to configure this'.)

I created csf user as explained in the CSF readme:
/home/csf/ (Owner csf:csf, Permissions 711)
/home/csf/public_html/ (Owner csf:nobody, Permissions 711)

The result: It works perfectly when I block my IP and try to visit the hostname. I get the expected message: 'The firewall on this server is blocking your connection.' But it fails to work for any other domain on the server—I just get the standard 'can't find the server' type browser error.

Any thoughts on why it wouldn't be working for virtual hosts?
Hi Kal
Do you solve this?

Regards
 

urgido

Verified User
Joined
Oct 28, 2008
Messages
401
Well, I am using messenger1 without problems.
messengerv3 is disabled.

I can view blocked message on all my hosted domains. Do you experimenting the same issue that you are not able to see the blocked message?

An issue that I am facing is that html message is not updated.

Regards
 
Top