CustomBuild 1.2 & PHP 6

panosru

Verified User
Joined
Oct 8, 2006
Messages
80
Location
Greece
Hello, I have a problem installing php 6

terminal said:
General settings
checking whether to include gcov symbols... no
checking whether to include debugging symbols... no
checking layout of installed files... PHP
checking path to configuration file... DEFAULT
checking where to scan for configuration files...
checking whether to enable PHP's own SIGCHLD handler... no
checking whether to explicitly link against libgcc... no
checking whether to enable short tags by default... yes
checking whether to enable dmalloc... no
checking whether to enable IPv6 support... yes
checking how big to make fd sets... using system default
checking for icu-config... no
checking for location of ICU headers and libraries... not found
configure: error: Unable to detect ICU prefix or no failed. Please verify ICU install prefix and make sure icu-config works.

*** There was an error while trying to configure php. Check the configure/ap2/configure.php6 file

server:/usr/local/directadmin/custombuild#
My configuration file for php is this:

/usr/local/directadmin/custombuild/configure/ap2/configure.php6 said:
#!/bin/sh
./configure \
--with-apxs2 \
--with-curl=/usr/local/lib \
--with-gd \
--enable-gd-native-ttf \
--with-ttf \
--with-gettext \
--with-jpeg-dir=/usr/local/lib \
--with-freetype-dir=/usr/local/lib \
--with-kerberos \
--with-openssl \
--with-mcrypt \
--with-mhash \
--with-mysql=/usr/local/mysql \
--with-mysqli=/usr/local/mysql/bin/mysql_config \
--with-pdo-mysql=/usr/local/mysql \
--with-pear \
--with-png-dir=/usr/local/lib \
--with-zlib \
--with-zlib-dir=/usr/local/lib \
--with-imap=/usr/local/imap-2007e \
--with-imap-ssl=/usr/local/imap-2007e \
--enable-zip \
--with-iconv=/usr/local \
--enable-bcmath \
--enable-calendar \
--enable-ftp \
--enable-magic-quotes \
--enable-sockets \
--enable-mbstring
EDIT:
I added this line on my configuration.php6 file --with-icu-dir=/usr/local/icu \ and worked but now I'm getting this error:

checking for external libmbfl... no
configure: error: multibyte regex support must be disabled, use --disable-mbregex

*** There was an error while trying to configure php. Check the configure/ap2/configure.php6 file

server:/usr/local/directadmin/custombuild#
I added the flag --disable-mbregex in my configuration file for now and PHP 6.0.0-dev installed but now php does not start.

EDIT2:
I returned but to php5 until php6 will released stable and support zend optimizer along with ioncube and source guardian.
 
Last edited:
Top